Bug 1476341 - linking error when using rte_eth_tx_done_cleanup function
linking error when using rte_eth_tx_done_cleanup function
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dpdk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 12:37 EDT by Timothy Redaelli
Modified: 2017-07-31 11:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1476337
Environment:
Last Closed: 2017-07-31 11:49:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Redaelli 2017-07-28 12:37:45 EDT
+++ This bug was initially created as a clone of Bug #1476337 +++

From release note of DPDK 17.05:

* **Added free Tx mbuf on demand API.**                                         
                                                                                
  Added a new function ``rte_eth_tx_done_cleanup()`` which allows an            
  application to request the driver to release mbufs that are no longer in use  
  from a Tx ring, independent of whether or not the ``tx_rs_thresh`` has been   
  crossed.

But the function is missing in map and so it can't be used by applications linking to shared libraries (like pktgen).

Upstream commit to backport:

commit 5b45c30a00ecbd5181e5679b13ca059bcd761ead
Author: Luca Boccassi <luca.boccassi@gmail.com>
Date:   Thu Jun 22 13:04:59 2017 +0100

    ethdev: add missing symbol in map
    
    The function rte_eth_tx_done_cleanup() was missing in the map file
    so it cannot be used by applications linking to shared libraries.
    pktgen uses it since version 3.2.0.
    
    Fixes: 44a718c457b5 ("ethdev: add API to free consumed buffers in Tx ring")
    Cc: stable@dpdk.org
    
    Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>

Note You need to log in before you can comment on or make changes to this bug.