Bug 1476342 - OSPd support for multiple hardware/use-cases
OSPd support for multiple hardware/use-cases
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
13.0 (Queens)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Angus Thomas
Amit Ugol
: FutureFeature
Depends On:
Blocks: 1419948 1458798
  Show dependency treegraph
 
Reported: 2017-07-28 12:40 EDT by John H Terpstra
Modified: 2017-10-23 04:21 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-23 04:21:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John H Terpstra 2017-07-28 12:40:27 EDT
Description of problem:

Split stack support - OSPd support for multiple hardware/use-cases
Comment 1 Sean Merrow 2017-07-31 10:30:05 EDT
Hi Arkay,

Regarding this RFE that was submitted for OSP 13, it looks to me like it may be a duplicate of 1418335. Can you please review that RFE (link below) and let us know if this is a duplicate. If it is not a duplicate, please detail what the difference is between them.


Bug 1418335 - [RFE] Easy heterogeneous cluster management [1]


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1418335

Thank you,
Sean
Comment 2 Sean Merrow 2017-07-31 10:30:28 EDT
Hi Arkady,

Regarding this RFE that was submitted for OSP 13, it looks to me like it may be a duplicate of 1418335. Can you please review that RFE (link below) and let us know if this is a duplicate. If it is not a duplicate, please detail what the difference is between them.


Bug 1418335 - [RFE] Easy heterogeneous cluster management [1]


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1418335

Thank you,
Sean
Comment 3 arkady kanevsky 2017-07-31 12:52:07 EDT
Sean,
https://bugzilla.redhat.com/show_bug.cgi?id=1418335 is specific subset for compute node only.

Consider the following 3 scenarios:
1. as an admin I want to configure configure subset of the openstack cluster for:
a. HPC - baremetal HW configuration as well openstack nova configuration is completely under HPC admin control.
b. NFV subcluster including specific node BIOS config for it, and specific neutron driver to use that maybe different than the one for rest of openstack.
c. portion of a cluster to be used for baremetal openshift  but managed from the same OSPd.
Comment 4 Jaromir Coufal 2017-08-01 16:20:42 EDT
Split Stack has been already implemented. If there is request for specific node config this belongs to HardProv.
Comment 5 Ramon Acedo 2017-10-23 04:21:05 EDT
I suggest to discuss details of the points described in comment #3 and then eventually create separate RFEs. Closing this one since split stack is implemented and supported.

Note You need to log in before you can comment on or make changes to this bug.