Bug 1476392 - typed_ast version needs to be 1.0.4
typed_ast version needs to be 1.0.4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python3-typed_ast (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 15:54 EDT by Troy Dawson
Modified: 2017-08-11 11:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: python3-typed_ast-1.0.4-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 11:58:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2017-07-28 15:54:27 EDT
Description of problem:
The current version of python3-typed_ast (1.0.3) is breaking mypy, which is the only package that depends on it.  It needs to be bumped up to version 1.0.4 to work with the version of python3-mypy that we have in Fedora.

Version-Release number of selected component (if applicable):
python3-typed_ast-1.0.3-1.fc27

How reproducible:
100% (in our tests)

Steps to Reproduce:
1. Try to build a package (such as pykickstart) that requires python3-mypy
2. koji build --scratch rawhide pykickstart-2.36-2.fc27.src.rpm
3.

Actual results:
Fails with the error
...
pkg_resources.ContextualVersionConflict: (typed-ast 1.0.3 (/usr/lib/python3.6/site-packages), Requirement.parse('typed-ast<1.1.0,>=1.0.4'), {'mypy'})
...
And then the usual tracebacks and error messages.

Expected results:
mypy to work correctly and rpm to build.

Additional info:
here is a build with python3-mypy-0.520-1.fc27
https://kojipkgs.fedoraproject.org//work/tasks/9943/20859943/build.log
here is a (scratch) build with python3-mypy-0.521-2.fc27
https://kojipkgs.fedoraproject.org//work/tasks/7854/20867854/build.log

Both give the same error.
Comment 1 Troy Dawson 2017-07-28 15:58:04 EDT
This is blocking some automated building for the bootstrap and module team.

We understand that time is important and that not everyone has much time to work on bugs.  If you are unable to update the rpm within two weeks, we will have a proven packager update the package version.
If you know you will be too busy and wouldn't mind us updating it sooner, just let us know.
Comment 2 Fedora Update System 2017-07-31 10:45:48 EDT
python3-typed_ast-1.0.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-22ca160bfb
Comment 3 Troy Dawson 2017-07-31 11:45:19 EDT
Thank you for your quick response.
Comment 4 Fedora Update System 2017-08-01 21:52:06 EDT
python3-typed_ast-1.0.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-22ca160bfb
Comment 5 Fedora Update System 2017-08-09 11:58:36 EDT
python3-typed_ast-1.0.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Martin 2017-08-09 18:01:07 EDT
FWIW mypy still does not work for me even after python3-typed-ast has been updated. It now complains that it can not find a module named "builtins".
Comment 7 Martin 2017-08-11 11:44:04 EDT
Filed bug #1480661 .

Note You need to log in before you can comment on or make changes to this bug.