Bug 147640 - Install of GFS-modules package doesn't update module dependencies
Summary: Install of GFS-modules package doesn't update module dependencies
Status: CLOSED DUPLICATE of bug 148001
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-09 23:46 UTC by Mike MacCana
Modified: 2010-01-12 03:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 15:40:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike MacCana 2005-02-09 23:46:56 UTC
Description of problem:
%post for GFS-modules doesn't update the module dependencies. If it did,
customers would be able to skip a step when adding new nodes to their clusters.
It'd also avoid a minor annoyance.

Version-Release number of selected component (if applicable):
6.0.0-10

Comment 1 Ken Preslan 2005-02-10 00:02:48 UTC
Reassign to package maintainer

Comment 2 Derek Anderson 2005-02-10 15:40:36 UTC
Setting to version 3 and closing as not a bug.  More recent versions of 
GFS-modules have fixed this issue. 
 
# rpm -qp --scripts GFS-modules-6.0.2-25.x86_64.rpm 
postinstall scriptlet (using /bin/sh): 
depmod -a 

Comment 3 Adam "mantis" Manthei 2005-02-14 19:10:59 UTC
Actually... this is a bug.  "depmod -a" only works for the currently running
kernel.  It doesn't work when installing GFS on to a system that is not booted
into the kernel that GFS is going to run.  For example, it won't work if you are
running kernel version 2.4.21-15 and you install GFS modules that are for kernel
version 2.4.21-27.0.1. This bug is a dup of bug #148001, marking it as such.

*** This bug has been marked as a duplicate of 148001 ***


Note You need to log in before you can comment on or make changes to this bug.