Bug 1476494 - AppStream metadata for Winetricks package are missing
AppStream metadata for Winetricks package are missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: winetricks (Show other bugs)
27
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-29 12:22 EDT by AsciiWolf
Modified: 2017-08-23 02:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: winetricks-20170731-1.fc26 winetricks-20170731-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-22 16:41:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description AsciiWolf 2017-07-29 12:22:23 EDT
Description of problem:

There is not any appdata.xml/metainfo.xml file available in the Winetricks package. Because of this, Winetricks cannot be found and/or installed using the GNOME Software application or another package manager UI based on AppStream.


Steps to Reproduce:

1. Open GNOME Software.
2. Type "winetricks".
Comment 1 Raphael Groner 2017-08-13 11:07:15 EDT
Thanks for your report. As I don't use GNOME currently, it's not possible to reproduce on my systems.
Could you provide some appdata.xml/metainfo.xml file to let me include it in the package? Maybe request it from upstream.
I'll close this bug for now, please feel free to reopen when there's some progress from upstream.
Comment 2 AsciiWolf 2017-08-13 11:14:05 EDT
I have already fixed this upstream.

https://github.com/Winetricks/winetricks/commit/43314ed7895396bfd625824d88b5e19c25f46cac
Comment 3 Raphael Groner 2017-08-13 11:51:17 EDT
*** Bug 1461836 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2017-08-13 17:04:16 EDT
winetricks-20170731-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6e03f963c4
Comment 5 Fedora Update System 2017-08-13 17:04:27 EDT
winetricks-20170731-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5b66f8a4e8
Comment 6 Fedora Update System 2017-08-14 23:49:50 EDT
winetricks-20170731-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6e03f963c4
Comment 7 Fedora Update System 2017-08-15 02:22:45 EDT
winetricks-20170731-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5b66f8a4e8
Comment 8 Jan Kurik 2017-08-15 02:32:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 9 Fedora Update System 2017-08-22 16:41:00 EDT
winetricks-20170731-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2017-08-23 02:06:47 EDT
winetricks-20170731-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.