Bug 1476500 - AppStream metadata for Phoronix Test Suite package are missing
AppStream metadata for Phoronix Test Suite package are missing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: phoronix-test-suite (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Markus Mayer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-29 13:10 EDT by AsciiWolf
Modified: 2017-08-01 14:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 14:14:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description AsciiWolf 2017-07-29 13:10:33 EDT
Description of problem:

There is not any appdata.xml/metainfo.xml file available in the Phoronix Test Suite package. Because of this, Phoronix Test Suite cannot be found and/or installed using the GNOME Software application or another package manager UI based on AppStream.


Steps to Reproduce:

1. Open GNOME Software.
2. Type "phoronix test suite".
Comment 1 AsciiWolf 2017-07-31 06:38:30 EDT
The upstream project already has an AppStream appdata file.

https://github.com/phoronix-test-suite/phoronix-test-suite/blob/master/pts-core/static/phoronix-test-suite.appdata.xml
Comment 2 Markus Mayer 2017-07-31 16:14:09 EDT
The appdata.xml is already installed by the rpm package.

I don't have a rawhide install here, but using GNOME Software on F25 finds and shows the phoronix test suite.

I've no idea how to debug AppStream related issues. Can you find some further information?
Comment 3 AsciiWolf 2017-08-01 03:14:50 EDT
I am not sure if there is any way to debug this, except the standard "appstream-util validate-relax foo.appdata.xml". I don't have any Fedora 25 system (just 26 and Rawhide) here, but if I remember correctly, it was not showing in GNOME Software on (64bit) F25 as well.
Comment 4 Markus Mayer 2017-08-01 13:25:44 EDT
I found some information about the AppStream database:

- The database is distributed via the 'appstream-data' package.
- The package is updated weekly

I check the content of the currecnt appstream-data package in rawhide. It contains the phoronix-test-suite.

May I ask you to update the appstream-data package to the latest version (27-3 as I'm writing this), and check if GNOME Software is able to find the phoronix-test-suite now?
Comment 5 AsciiWolf 2017-08-01 14:14:47 EDT
It looks like the Phoronix Test Suite is now showing in GNOME Software in Rawhide, after the appstream-data upgrade. Thanks!

Note You need to log in before you can comment on or make changes to this bug.