Bug 1476561 - [UI] - Subnets sub tab in network tab shouldn't appear while we don't use external network with subnet
[UI] - Subnets sub tab in network tab shouldn't appear while we don't use ext...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.2.0
x86_64 Linux
low Severity low (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ales Musil
Ori Ben Sasson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-30 06:55 EDT by Ori Ben Sasson
Modified: 2017-12-20 06:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:18:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
screen recording (1.73 MB, application/ogg)
2017-07-30 06:55 EDT, Ori Ben Sasson
no flags Details
screen recording (11.65 MB, application/octet-stream)
2017-08-14 05:11 EDT, Ales Musil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79696 None None None 2017-08-16 02:56 EDT

  None (edit)
Description Ori Ben Sasson 2017-07-30 06:55:39 EDT
Created attachment 1306543 [details]
screen recording

Description of problem:
[UI] - Subnets sub tab in network tab shouldn't appear while we don't use external network with subnet

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170728194615.gitec6aa15.el7.centos.noarch

How reproducible:
100

Steps to Reproduce:
1. Create network
2. Click on the network that you created

Actual results:
Subnets sub tab appear

Expected results:
Subnets sub tab should not appear
Comment 1 Red Hat Bugzilla Rules Engine 2017-08-02 03:37:42 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Ales Musil 2017-08-14 05:11 EDT
Created attachment 1313003 [details]
screen recording

I can't reproduce this bug on current master. I suspect that this patch fixed this issue: https://gerrit.ovirt.org/#/c/79696/

Can you fetch the latest master and try it again to see if it is really fixed?
Comment 3 Ori Ben Sasson 2017-08-21 02:12:18 EDT
Verified on 4.2.0-0.0.master.20170818152502.gita8c361f.el7.centos
Comment 4 Sandro Bonazzola 2017-12-20 06:18:47 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.