Bug 1476675 - [trello 3GxVdfi4] 3.7 Origin, Clear Changes option is not working
[trello 3GxVdfi4] 3.7 Origin, Clear Changes option is not working
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.7.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.7.0
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 03:29 EDT by yapei
Modified: 2017-08-08 21:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 21:50:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yapei 2017-07-31 03:29:48 EDT
Description of problem:
In 3.7 Origin env, Clicking "Clear Changes" doesn't reset data to original ones on web console

Version-Release number of selected component (if applicable):
openshift v3.6.0-rc.0+9636556-361
kubernetes v1.7.0+695f48a16f


How reproducible:
Always

Steps to Reproduce:
1. Create Resource, such as DC
$ oc run myrundc --image=aosqe/hello-openshift
2. Go to web console, Deployments -> myrundc -> Environment tab
3. Click "Add Environment Variable", add env1:envvalue1 and Save
4. Check if env vars were added successfully
$ oc get dc myrundc -o yaml
...
    spec:
      containers:
      - env:
        - name: env1
          value: value1
.....
5. Access Deployments -> myrundc -> Environment tab again, update envvalue1 to envvalue1update, DO NOT Save but click "Clear Changes" this time
6. Access Deployments -> myrundc -> Environment tab again, click Delete(X) icon for env vars, DO NOT Save but click "Clear Changes"


Actual results:
5. After clicking "Clear Changes", the env vars on web console is shown as env1:envvalue1update
6. No env vars will be shown

Expected results:
5. The env vars should be shown as "env1:envvalue1", "Clear Changes" should restore data to the one before change
6. After clicking "Clear Changes", env1:envvalue1 should still show up on the page

Additional info:
Comment 3 yapei 2017-08-08 03:36:29 EDT
Tested against 
openshift v3.6.0-rc.0+6c7b12e-523
kubernetes v1.7.0+695f48a16f

where PR #1894 is merged
[root@ip-172-18-7-99 origin-web-console]# git log | grep '#1894'
    Merge pull request #1894 from spadgett/env-clear


Follow the actions in "Steps to Reproduce", now the issue has been resolved. Clear Changes link works well.

QE could verify when it's changed to ON_QA
Comment 4 yapei 2017-08-08 20:26:42 EDT
Move to VERIFIED since the function has been checked

Note You need to log in before you can comment on or make changes to this bug.