Bug 147668 - [RFE] upgrade teTeX to 3.0
[RFE] upgrade teTeX to 3.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
: FutureFeature
: 147329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 06:08 EST by Takanori MATSUURA
Modified: 2013-07-02 19:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 08:17:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tetex-3.0 SRPM (221.78 KB, application/octet-stream)
2005-02-10 06:08 EST, Takanori MATSUURA
no flags Details
latex2html-2002.2.1 SRPM (6.50 KB, application/octet-stream)
2005-02-10 06:10 EST, Takanori MATSUURA
no flags Details
texi2html-1.76 SRPM (5.79 KB, application/octet-stream)
2005-02-10 06:12 EST, Takanori MATSUURA
no flags Details
tetex-3.0-1.nosrc.rpm (187.97 KB, application/octet-stream)
2005-02-10 16:16 EST, Jindrich Novy
no flags Details

  None (edit)
Description Takanori MATSUURA 2005-02-10 06:08:11 EST
Description of problem:
Now teTeX-3.0 is released.
So let's upgrade teTeX package to 3.0.


Additional info:
I also request that latex2html and texi2html should be separated from tetex SRPM.

I'll attach tetex, latex2html, and texi2html nosrc SRPMs that omits sources
available vir FTP/HTTP.
Comment 1 Takanori MATSUURA 2005-02-10 06:08:11 EST
Created attachment 110915 [details]
tetex-3.0 SRPM
Comment 2 Takanori MATSUURA 2005-02-10 06:10:39 EST
Created attachment 110916 [details]
latex2html-2002.2.1 SRPM
Comment 3 Takanori MATSUURA 2005-02-10 06:12:06 EST
Created attachment 110917 [details]
texi2html-1.76 SRPM

This SRPM solves Bug 121889.
Comment 4 Jindrich Novy 2005-02-10 09:50:10 EST
MATSUURA, thanks!

The updated spec looks very nice, I'm reviewing it now and syncing it
with some modifications I made. I need to ask you a few questions
first. I looked into the browser patch you added, what about
links/elinks support when we have there lynx and w3m?
Comment 5 Jindrich Novy 2005-02-10 13:57:53 EST
Why not to apply xdvik-xdvi-resources.patch ?
Comment 6 Jindrich Novy 2005-02-10 16:10:50 EST
*** Bug 147329 has been marked as a duplicate of this bug. ***
Comment 7 Jindrich Novy 2005-02-10 16:16:44 EST
Created attachment 110939 [details]
tetex-3.0-1.nosrc.rpm

Please review my changes and test it.
Comment 8 Jindrich Novy 2005-02-10 16:21:41 EST
Note that the build is fine on i386, but fails on ppc in
tetex-src-3.0/texk/xdvik/gui:

gcc -DHAVE_CONFIG_H  -I. -I. -I../.. -I../.. -W -Wall -Wunused -I..
-I./.. -I/usr/X11R6/include -DPS_GS  -DXSERVER_INFO  -O2 -g -pipe
-Wp,-D_FORTIFY_SOURCE=2 -m32 -fsigned-char  -c xm_prefs_helpers.c -o
xm_prefs_helpers.o
/bin/sh ./mksedscript . pkpath sizes vfpath \
figpath headerpath -DHAVE_CONFIG_H  -W -Wall -Wunused
-I../../libs/t1lib -I./../../libs/t1lib -I../../libs/t1lib/../type1
-I./../../libs/t1lib/../type1 -DPS_GS  -I./gui
-I../../libs/t1lib/lib/t1lib -I../kpathsea -I/usr/X11R6/include 
>sedscript
gcc -DHAVE_CONFIG_H  -I. -I. -I../.. -I../.. -W -Wall -Wunused -I..
-I./.. -I/usr/X11R6/include -DPS_GS  -DXSERVER_INFO  -O2 -g -pipe
-Wp,-D_FORTIFY_SOURCE=2 -m32 -fsigned-char  -c xm_toolbar.c -o
xm_toolbar.o
gcc -DHAVE_CONFIG_H  -I. -I. -I../.. -I../.. -W -Wall -Wunused -I..
-I./.. -I/usr/X11R6/include -DPS_GS  -DXSERVER_INFO  -O2 -g -pipe
-Wp,-D_FORTIFY_SOURCE=2 -m32 -fsigned-char  -c xm_toolbar.c -o
xm_toolbar.o
gcc -o squeeze   squeeze.o
sed -f sedscript <./xdvi.1.in >xdvi.1
./squeeze ./psheader.txt psheader.c
gcc -DHAVE_CONFIG_H  -I. -I. -I.. -I./.. -W -Wall -Wunused
-I../../libs/t1lib -I./../../libs/t1lib -I../../libs/t1lib/../type1
-I./../../libs/t1lib/../type1 -DPS_GS  -I./gui
-I../../libs/t1lib/lib/t1lib -I../kpathsea -I/usr/X11R6/include   -O2
-g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -fsigned-char  -c psheader.c -o
psheader.o
rm -f libgui.a
ar rc libgui.a help-window.o message-window.o mag.o menu.o Panner.o
pagesel.o print-dialog.o print-log.o search-dialog.o selection.o
sfDir.o sfDraw.o sfPath.o sfSelFile.o statusline.o Tip.o
topic-window.o xaw_bitmaps.o xaw_menu.o xicon.o xlwradio.o
xm_colorsel.o xm_filesel.o xm_menu.o xm_prefs.o xm_prefs_appearance.o
xm_prefs_fonts.o xm_prefs_page.o xm_prefs_scroll.o xm_prefs_helpers.o
xm_toolbar.o
rm -f libgui.a
ar: libgui.a: No such file or directory
ar rc libgui.a help-window.o message-window.o mag.o menu.o Panner.o
pagesel.o print-dialog.o print-log.o search-dialog.o selection.o
sfDir.o sfDraw.o sfPath.o sfSelFile.o statusline.o Tip.o
topic-window.o xaw_bitmaps.o xaw_menu.o xicon.o xlwradio.o
xm_colorsel.o xm_filesel.o xm_menu.o xm_prefs.o xm_prefs_appearance.o
xm_prefs_fonts.o xm_prefs_page.o xm_prefs_scroll.o xm_prefs_helpers.o
xm_toolbar.o
make[3]: *** [libgui.a] Error 1
make[3]: Leaving directory
`/usr/src/build/519099-ppc/BUILD/tetex-src-3.0/texk/xdvik/gui'
make[2]: *** [gui/libgui.a] Error 2
make[2]: *** Waiting for unfinished jobs....
ranlib libgui.a
make[3]: Leaving directory
`/usr/src/build/519099-ppc/BUILD/tetex-src-3.0/texk/xdvik/gui'
make[2]: Leaving directory
`/usr/src/build/519099-ppc/BUILD/tetex-src-3.0/texk/xdvik'
make[1]: *** [all] Error 1
make[1]: Leaving directory
`/usr/src/build/519099-ppc/BUILD/tetex-src-3.0/texk'
make: *** [all] Error 1
error: Bad exit status from
/usr/src/build/519099-ppc/install-tmp/rpm-tmp.6145 (%build)

Comment 9 Jindrich Novy 2005-02-10 16:26:10 EST
The build failure prevented me from letting the package be available
in devel. If you want to have a SRPM with all sources included,
download it from:

http://people.redhat.com/jnovy/files/tetex-3.0-1.src.rpm
Comment 10 Takanori MATSUURA 2005-02-14 04:43:16 EST
(In reply to comment #5)
> Why not to apply xdvik-xdvi-resources.patch ?

Because this patch is basically fixed only decoration of xdvi window
and not effect its functionality. Moreover I think default decoration
settings are more familiar to the default desktop environment in
Fedora Core.

Browser part is included in tetex-3.0-browser.patch.
Comment 11 Jindrich Novy 2005-02-15 11:19:08 EST
I just successfully built the tetex-3.0-1 package. Please test it and
open new bugs if you see a new problem.

Thanks,
Jindrich
Comment 12 Takanori MATSUURA 2005-02-15 23:01:18 EST
Basically OK except for dvipsk-jpatch-p1.6a1-pdvips.patch.

The patch included in attachment 110939 [details] returns some rejection. Please
use the patch included in attachement 110915.
Comment 13 Takanori MATSUURA 2005-02-17 00:52:41 EST
(In reply to comment #12)
> Basically OK except for dvipsk-jpatch-p1.6a1-pdvips.patch.

OK. please close this bug.
I opened Bug 148947 for this problem.
Comment 14 Jindrich Novy 2005-02-17 09:12:10 EST
The bug is not completed yet, please note that I haven't added new texi2html and
latex2html packages what needs to be done before closing this.
Comment 15 Jindrich Novy 2005-03-16 08:17:08 EST
texi2html package is now built in rawhide and latex2html in now included to CVS
and will be built soon.

Note You need to log in before you can comment on or make changes to this bug.