Bug 1476683 - Squid mount point missing in storage requirements
Squid mount point missing in storage requirements
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Documentation (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Stephen Wadeley
Sergei Petrosian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 03:48 EDT by Lukas Zapletal
Modified: 2018-05-17 03:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-17 03:51:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2017-07-31 03:48:03 EDT
Document URL: 
https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/installation_guide/preparing_your_environment_for_installation

Section Number and Name: 
2.1. STORAGE REQUIREMENTS AND RECOMMENDATIONS

Describe the issue: 
Satellite 6.2 uses Squid backend engine to cache RPM files for "On-demand" repositories. It fills up pretty quickly and since by default it's on root folder (/) the outcome is bad - Satellite 6 stops operating properly.

Suggestions for improvement: 

Please document how to setup mountpoint for Squid, provide some info about its sizing and also add configuration for Squid (setting up directory structure for directories - by default the cache is small).
Comment 5 Lukas Zapletal 2018-05-17 03:51:33 EDT
Okay sorry I am closing this, I was wrong. Squid cache is temporary and 10 GB is enough. Pulp then fetches the files into it's own directory and the space can be reclaimed.

https://docs.pulpproject.org/dev-guide/design/deferred-download.html#squid-cache
Comment 6 Stephen Wadeley 2018-05-17 03:54:01 EDT
Thank you lzap

Note You need to log in before you can comment on or make changes to this bug.