Bug 1476735 - Fix default setting of %_debugsource_packages and %_debuginfo_subpackages to not break testsuite
Fix default setting of %_debugsource_packages and %_debuginfo_subpackages to ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 06:06 EDT by Mark Wielaard
Modified: 2017-07-31 10:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: redhat-rpm-config-67-1.fc27 rpm-4.13.0.1-41.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 10:01:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wielaard 2017-07-31 06:06:51 EDT
Description of problem:

rpm-4.13.0.1-37 enabled %_debugsource_packages and %_debuginfo_subpackages by patching macros.in.

This caused the testsuite to fail since the tests are setup to selectively enable/disable these. The upstream default rpm settings are split like the fedora rpm/redhat-rpm-config settings. With macros.in setting the default and macros.debug for those tests that need debug packages.

Unfortunately this means that %check now ignores any test failures again. Which can catch build or toolchain issues.

The best fix, IMHO, would be to leave the upstream defaults alone and move the setting of %_debugsource_packages and %_debuginfo_subpackages to redhat-rpm-config default macros. This is also how other debug packages defaults are set like %_enable_debug_packages and %_include_minidebuginfo.
Comment 1 Igor Gnatenko 2017-07-31 06:08:00 EDT
I think we should just do --undefine from respective tests...
Comment 2 Mark Wielaard 2017-07-31 06:09:20 EDT
Somewhat related "macros should include %_include_gdb_index 1 to generate .gdb_index sections by default" https://bugzilla.redhat.com/show_bug.cgi?id=1476722 Probably good to fix these together.

Note You need to log in before you can comment on or make changes to this bug.