Bug 1476909 - python2-rpkg dependency on koji broken in EL6
python2-rpkg dependency on koji broken in EL6
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rpkg (Show other bugs)
el6
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: cqi
Fedora Extras Quality Assurance
:
: 1477429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 15:16 EDT by Martin Langhoff
Modified: 2017-08-02 01:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 13:02:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Langhoff 2017-07-31 15:16:00 EDT
Description of problem:

With the change in python2-rpkg-1.49-6, it is no longer possible to install python2-rpkg (impacts fedpkg on EL6).

* Mon Jul 10 2017 Chenxiong Qi <cqi@redhat.com> - 1.49-6
  - Rename koji to python2-koji

As far a s I can see, koji has been renamed (and/or 'provides') python2-koji on EL7, but not on EL6.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. yum -y install fedpkg

Actual results:

Error: Package: python2-rpkg-1.49-6.el6.noarch (epel)
           Requires: python2-koji

Additional info: BZ#1470703 seems related.
Comment 1 Dennis Gilmore 2017-07-31 18:07:27 EDT
koji with appropriate provides is in testing
Comment 2 Martin Langhoff 2017-08-01 13:02:20 EDT
I can confirm that the packages from testing fix the issue. Thanks Dennis!
Comment 3 cqi 2017-08-02 01:22:57 EDT
*** Bug 1477429 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.