Bug 1476941 - Designate documentation needs to specify the pool to attach to
Designate documentation needs to specify the pool to attach to
Status: CLOSED DUPLICATE of bug 1423360
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Lopes
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 17:21 EDT by Ruchika K
Modified: 2017-08-01 23:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 23:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruchika K 2017-07-31 17:21:27 EDT
Description of problem:
I followed the steps here:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/dns-as-a-service_guide/manual_dnsaas_installation

sudo yum install openstack-designate-api openstack-designate-central openstack-designate-sink openstack-designate-pool-manager openstack-designate-mdns openstack-designate-common python-designate python-designateclient openstack-designate-agent
Loaded plugins: product-id, search-disabled-repos, subscription-manager
No package openstack-designate-api available.
No package openstack-designate-central available.
No package openstack-designate-sink available.
No package openstack-designate-pool-manager available.
No package openstack-designate-mdns available.
No package openstack-designate-common available.
No package python-designate available.
No package openstack-designate-agent available.
Nothing to do



The node is registered with the employee sub on it.

Would be good to include what needs to be done before installing these packages.


Version-Release number of selected component (if applicable):


How reproducible:

100%
Steps to Reproduce:
1.register the controller node
2.attach employee sub
3.Run step 1 here https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html/dns-as-a-service_guide/manual_dnsaas_installation

Actual results:


Expected results:


Additional info:
Comment 1 Ruchika K 2017-07-31 17:41:12 EDT
It would be good to include this in the documentation in the DNSaas prerequisites

- register your system
- attach the right pool

sudo subscription-manager repos --disable=*
sudo subscription-manager repos --enable=rhel-7-server-rpms --enable=rhel-7-server-extras-rpms --enable=rhel-7-server-rh-common-rpms
--enable=rhel-ha-for-rhel-7-server-rpms --enable=rhel-7-server-openstack-10-rpms
Comment 2 Ruchika K 2017-07-31 17:41:12 EDT
It would be good to include this in the documentation in the DNSaas prerequisites

- register your system
- attach the right pool

sudo subscription-manager repos --disable=*
sudo subscription-manager repos --enable=rhel-7-server-rpms --enable=rhel-7-server-extras-rpms --enable=rhel-7-server-rh-common-rpms
--enable=rhel-ha-for-rhel-7-server-rpms --enable=rhel-7-server-openstack-10-rpms
Comment 4 Martin Lopes 2017-08-01 23:32:55 EDT
Thanks for the suggestion. I'll address this by linking to the existing steps for system registration: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/10/html-single/director_installation_and_usage/#sect-Registering_your_System
Comment 5 Martin Lopes 2017-08-01 23:35:24 EDT
Moving this work to the large DNSaaS bug, so that all the changes can be added in together as a single transaction.
Comment 6 Martin Lopes 2017-08-01 23:35:37 EDT

*** This bug has been marked as a duplicate of bug 1423360 ***

Note You need to log in before you can comment on or make changes to this bug.