Bug 1476950 - ValueError: device is already in tree
ValueError: device is already in tree
Status: CLOSED DUPLICATE of bug 1393382
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:84432eb48135296f114dbc0f5f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-31 18:44 EDT by Jonathan Nicol
Modified: 2017-07-31 20:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 20:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (302.53 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: anaconda.log (6.83 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: environ (529 bytes, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: lsblk_output (2.49 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: nmcli_dev_list (1.35 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: os_info (447 bytes, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: storage.log (31.83 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: syslog (236.00 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: ifcfg.log (1.52 KB, text/plain)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details
File: program.log (12.35 KB, application/octet-stream)
2017-07-31 18:44 EDT, Jonathan Nicol
no flags Details

  None (edit)
Description Jonathan Nicol 2017-07-31 18:44:04 EDT
Version-Release number of selected component:
anaconda-26.21.11-1

The following was filed automatically by anaconda:
anaconda 26.21.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/devicetree.py", line 148, in _add_device
    raise ValueError("device is already in tree")
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/helpers/partition.py", line 111, in run
    self._devicetree._add_device(device)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 306, in handle_device
    device = helper_class(self, info).run()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 519, in _populate
    self.handle_device(dev)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/populator/populator.py", line 454, in populate
    self._populate()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 271, in reset
    self.devicetree.populate(cleanup_only=cleanup_only)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/osinstall.py", line 1175, in storage_initialize
    storage.reset()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self)
ValueError: device is already in tree

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/libexec/system-python  /sbin/anaconda
cmdline_file:   initrd=Fedora26/initrd.img method=http://mirrors.kernel.org/fedora/releases/26/Workstation/x86_64/os/ modprobe.blacklist=nouveau BOOT_IMAGE=Fedora26/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        26
Comment 1 Jonathan Nicol 2017-07-31 18:44:09 EDT
Created attachment 1307292 [details]
File: anaconda-tb
Comment 2 Jonathan Nicol 2017-07-31 18:44:10 EDT
Created attachment 1307293 [details]
File: anaconda.log
Comment 3 Jonathan Nicol 2017-07-31 18:44:11 EDT
Created attachment 1307294 [details]
File: environ
Comment 4 Jonathan Nicol 2017-07-31 18:44:12 EDT
Created attachment 1307295 [details]
File: lsblk_output
Comment 5 Jonathan Nicol 2017-07-31 18:44:13 EDT
Created attachment 1307296 [details]
File: nmcli_dev_list
Comment 6 Jonathan Nicol 2017-07-31 18:44:13 EDT
Created attachment 1307297 [details]
File: os_info
Comment 7 Jonathan Nicol 2017-07-31 18:44:14 EDT
Created attachment 1307298 [details]
File: storage.log
Comment 8 Jonathan Nicol 2017-07-31 18:44:16 EDT
Created attachment 1307299 [details]
File: syslog
Comment 9 Jonathan Nicol 2017-07-31 18:44:17 EDT
Created attachment 1307300 [details]
File: ifcfg.log
Comment 10 Jonathan Nicol 2017-07-31 18:44:18 EDT
Created attachment 1307301 [details]
File: program.log
Comment 11 Jonathan Nicol 2017-07-31 20:07:46 EDT
Aha, I suspect this is a duplicate of 1430155 / 1393382. I do have former-RAID drives. Will reformat and retry.

*** This bug has been marked as a duplicate of bug 1393382 ***

Note You need to log in before you can comment on or make changes to this bug.