Bug 1477001 - Rpm is not persistent after upgrade to rhvh-4.1-20170728.0
Rpm is not persistent after upgrade to rhvh-4.1-20170728.0
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: Installation & Update (Show other bugs)
4.1
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-4.1.4-1
: ---
Assigned To: Yuval Turgeman
Huijuan Zhao
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 00:03 EDT by Huijuan Zhao
Modified: 2017-08-23 04:06 EDT (History)
15 users (show)

See Also:
Fixed In Version: imgbased-0.9.37-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 04:06:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+
mgoldboi: planning_ack+
sbonazzo: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
Sosreport, all logs in /var/log and /tmp from host (9.69 MB, application/x-gzip)
2017-08-01 00:03 EDT, Huijuan Zhao
no flags Details
Comment 1: repo for httpd (308 bytes, text/plain)
2017-08-01 22:43 EDT, Huijuan Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80043 master MERGED persist: overriding machine-id when using nspawn 2017-08-01 07:54 EDT
oVirt gerrit 80052 ovirt-4.1 MERGED persist: overriding machine-id when using nspawn 2017-08-01 07:55 EDT
oVirt gerrit 80087 master MERGED persist: running nspawn with a permissive domain 2017-08-02 09:51 EDT
oVirt gerrit 80116 ovirt-4.1 MERGED persist: running nspawn with a permissive domain 2017-08-02 09:52 EDT

  None (edit)
Description Huijuan Zhao 2017-08-01 00:03:42 EDT
Created attachment 1307352 [details]
Sosreport,  all logs in /var/log and /tmp from host

Description of problem:
Rpm is not persistent after upgrade to rhvh-4.1-20170728.0


Version-Release number of selected component (if applicable):
From: redhat-virtualization-host-4.1-20170616.0
To:   redhat-virtualization-host-4.1-20170728.0
      imgbased-0.9.36-0.1.el7ev.noarch

# imgbase layout
rhvh-4.1-0.20170616.0
 +- rhvh-4.1-0.20170616.0+1
rhvh-4.1-0.20170728.0
 +- rhvh-4.1-0.20170728.0+1


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170616.0
2. Setup repo and install rpm httpd in rhvh:
   # yum install httpd
3. Check whether rpm httpd is installed successful:
   # rpm -qa | grep httpd
   # ls /var/imgbased/persisted-rpms/
4. Setup local repos and upgrade rhvh to rhvh-4.1-0.20170728.0:
   # yum update
5. Reboot and login new layer rhvh-4.1-0.20170728.0, check whether rpm httpd is persistent after upgrade to rhvh-4.1-20170728.0:
   # rpm -qa | grep httpd
   # ls /var/imgbased/persisted-rpms/


Actual results:
1. After step3, rpm httpd is installed successful:

# rpm -qa | grep httpd
httpd-tools-2.4.6-45.el7.x86_64
httpd-2.4.6-45.el7.x86_64

# ls /var/imgbased/persisted-rpms/
apr-1.4.8-3.el7.x86_64.rpm  apr-util-1.5.2-6.el7.x86_64.rpm  httpd-2.4.6-45.el7.x86_64.rpm  httpd-tools-2.4.6-45.el7.x86_64.rpm  mailcap-2.1.41-2.el7.noarch.rpm

2. After step5, rpm httpd is not persistent:

# rpm -qa | grep httpd

# ls /var/imgbased/persisted-rpms/
apr-1.4.8-3.el7.x86_64.rpm  apr-util-1.5.2-6.el7.x86_64.rpm  httpd-2.4.6-45.el7.x86_64.rpm  httpd-tools-2.4.6-45.el7.x86_64.rpm  mailcap-2.1.41-2.el7.noarch.rpm


Expected results:
1. After step5, rpm httpd should be persistent, the results should be same as step3.


Additional info:
No such issue in rhvh-4.1-0.20170721.0, so this is regression issue.
Comment 1 Huijuan Zhao 2017-08-01 22:40:36 EDT
Still encountered this issue in imgbased-0.9.37-0.1.el7ev.


Test version:
From: redhat-virtualization-host-4.1-20170616.0
To:   redhat-virtualization-host-4.1-20170801.0
      imgbased-0.9.37-0.1.el7ev.noarch

# imgbase layout
rhvh-4.1-0.20170616.0
 +- rhvh-4.1-0.20170616.0+1
rhvh-4.1-0.20170801.0
 +- rhvh-4.1-0.20170801.0+1


Test steps:
Same as comment 0.


Actual results:
After step5, rpm httpd is not persistent:

# rpm -qa | grep httpd

# ls /var/imgbased/persisted-rpms/
apr-1.4.8-3.el7.x86_64.rpm  apr-util-1.5.2-6.el7.x86_64.rpm  httpd-2.4.6-45.el7.x86_64.rpm  httpd-tools-2.4.6-45.el7.x86_64.rpm  mailcap-2.1.41-2.el7.noarch.rpm


Expected results:
After step5, rpm httpd should be persistent.


Additional info:
1. After step5, install httpd manually, can install successful:

# yum install httpd
Loaded plugins: imgbased-persist, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Repo rhel-7-server-rhvh-4-source-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-source-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Repo rhel-7-server-rhvh-4-beta-debug-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-beta-debug-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Repo rhel-7-server-rhvh-4-debug-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-debug-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Repo rhel-7-server-rhvh-4-beta-source-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-beta-source-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Repo rhel-7-server-rhvh-4-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Repo rhel-7-server-rhvh-4-beta-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877.pem
Repo rhel-7-server-rhvh-4-beta-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/5858345830546115877-key.pem
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.4.6-45.el7 will be installed
--> Processing Dependency: httpd-tools = 2.4.6-45.el7 for package: httpd-2.4.6-45.el7.x86_64
--> Processing Dependency: /etc/mime.types for package: httpd-2.4.6-45.el7.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.4.6-45.el7.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.4.6-45.el7.x86_64
--> Running transaction check
---> Package apr.x86_64 0:1.4.8-3.el7 will be installed
---> Package apr-util.x86_64 0:1.5.2-6.el7 will be installed
---> Package httpd-tools.x86_64 0:2.4.6-45.el7 will be installed
---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================
 Package                                   Arch                                 Version                                    Repository                            Size
======================================================================================================================================================================
Installing:
 httpd                                     x86_64                               2.4.6-45.el7                               rhel73                               1.2 M
Installing for dependencies:
 apr                                       x86_64                               1.4.8-3.el7                                rhel73                               103 k
 apr-util                                  x86_64                               1.5.2-6.el7                                rhel73                                92 k
 httpd-tools                               x86_64                               2.4.6-45.el7                               rhel73                                84 k
 mailcap                                   noarch                               2.1.41-2.el7                               rhel73                                31 k

Transaction Summary
======================================================================================================================================================================
Install  1 Package (+4 Dependent packages)

Total download size: 1.5 M
Installed size: 4.3 M
Is this ok [y/d/N]: y
Downloading packages:
(1/5): apr-1.4.8-3.el7.x86_64.rpm                                                                                                              | 103 kB  00:00:03     
(2/5): apr-util-1.5.2-6.el7.x86_64.rpm                                                                                                         |  92 kB  00:00:03     
(3/5): httpd-tools-2.4.6-45.el7.x86_64.rpm                                                                                                     |  84 kB  00:00:01     
(4/5): mailcap-2.1.41-2.el7.noarch.rpm                                                                                                         |  31 kB  00:00:00     
(5/5): httpd-2.4.6-45.el7.x86_64.rpm                                                                                                           | 1.2 MB  00:00:21     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                  60 kB/s | 1.5 MB  00:00:24     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : apr-1.4.8-3.el7.x86_64                                                                                                                             1/5 
  Installing : apr-util-1.5.2-6.el7.x86_64                                                                                                                        2/5 
  Installing : httpd-tools-2.4.6-45.el7.x86_64                                                                                                                    3/5 
  Installing : mailcap-2.1.41-2.el7.noarch                                                                                                                        4/5 
  Installing : httpd-2.4.6-45.el7.x86_64                                                                                                                          5/5 
  Verifying  : httpd-tools-2.4.6-45.el7.x86_64                                                                                                                    1/5 
  Verifying  : apr-util-1.5.2-6.el7.x86_64                                                                                                                        2/5 
  Verifying  : mailcap-2.1.41-2.el7.noarch                                                                                                                        3/5 
  Verifying  : httpd-2.4.6-45.el7.x86_64                                                                                                                          4/5 
  Verifying  : apr-1.4.8-3.el7.x86_64                                                                                                                             5/5 

Installed:
  httpd.x86_64 0:2.4.6-45.el7                                                                                                                                         

Dependency Installed:
  apr.x86_64 0:1.4.8-3.el7            apr-util.x86_64 0:1.5.2-6.el7            httpd-tools.x86_64 0:2.4.6-45.el7            mailcap.noarch 0:2.1.41-2.el7           

Complete!


# rpm -qa | grep httpd
httpd-tools-2.4.6-45.el7.x86_64
httpd-2.4.6-45.el7.x86_64


2. Attached httpd repo.
Comment 2 Huijuan Zhao 2017-08-01 22:43 EDT
Created attachment 1307859 [details]
Comment 1: repo for httpd
Comment 3 Huijuan Zhao 2017-08-02 22:48:50 EDT
Test version:
From: redhat-virtualization-host-4.1-20170616.0
To:   redhat-virtualization-host-4.1-20170802.0
      imgbased-0.9.38-0.1.el7ev.noarch

# imgbase layout
rhvh-4.1-0.20170616.0
 +- rhvh-4.1-0.20170616.0+1
rhvh-4.1-0.20170802.0
 +- rhvh-4.1-0.20170802.0+1


Test steps:
Same as comment 0.


Test results:
After step5, the rpm httpd is persistent.

# rpm -qa | grep httpd
httpd-2.4.6-45.el7.x86_64
httpd-tools-2.4.6-45.el7.x86_64

# ls /var/imgbased/persisted-rpms/
apr-1.4.8-3.el7.x86_64.rpm  apr-util-1.5.2-6.el7.x86_64.rpm  httpd-2.4.6-45.el7.x86_64.rpm  httpd-tools-2.4.6-45.el7.x86_64.rpm  mailcap-2.1.41-2.el7.noarch.rpm


So this bug is fixed in imgbased-0.9.38-0.1.el7ev.noarch, I will change the status to VERIFIED when the status is ON_QA.
Comment 5 Huijuan Zhao 2017-08-02 23:21:54 EDT
According to comment 3, change the status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.