Bug 1477054 - [Cavium 6.8 Bug] - L2 iSCSI boot failure in MPIO configuration [NEEDINFO]
[Cavium 6.8 Bug] - L2 iSCSI boot failure in MPIO configuration
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.8
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Chris Leech
Storage QE
:
Depends On:
Blocks: 1383344 1425546
  Show dependency treegraph
 
Reported: 2017-08-01 03:07 EDT by Nilesh Javali
Modified: 2017-11-28 14:47 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 14:47:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nilesh.javali: needinfo? (girisha.davanageri)


Attachments (Terms of Use)
serial logs for the OS boot failure (53.77 KB, text/plain)
2017-08-01 03:07 EDT, Nilesh Javali
no flags Details
DUD used to update drivers (4.04 MB, application/octet-stream)
2017-08-01 03:10 EDT, Nilesh Javali
no flags Details
iBFT info at dracut shell (386.76 KB, image/png)
2017-08-01 03:11 EDT, Nilesh Javali
no flags Details
eth0 and eth1 info at dracut shell (429.84 KB, image/png)
2017-08-01 03:12 EDT, Nilesh Javali
no flags Details
manual iscsistart login at dracut shell (484.00 KB, image/png)
2017-08-01 03:13 EDT, Nilesh Javali
no flags Details

  None (edit)
Description Nilesh Javali 2017-08-01 03:07:13 EDT
Created attachment 1307392 [details]
serial logs for the OS boot failure

Description of problem:
RHEL 6.8 OS installation is successful in L2 iSCSI boot (non-offload solution) with MPIO configuration. The OS fails to boot and falls to dracut shell at the pre-pivot stage. 

Version-Release number of selected component (if applicable):
RHEL 6.8 GA release

How reproducible:
Always

Steps to Reproduce:
1. Setup details:
HPE Synergy BL480c G10 blades with Bronco (HPE Synergy 3820C 10/20Gb Converged Network Adapter) using offload iSCSI OV profile.
 
2. Perform L2 iSCSI boot OS installation using kernel cmdline params ip=ibft, selinux=0, linux dd.
 
3. Apply netxtreme2-7.14.29-dd-rhel6u8-2.6.32_642.el6-x86_64.iso DUD (attached here).
 
4. When OS is installed, and just before reboot, fall to the shell and check the network scripts under /etc/sysconfig/network-scripts/ifcfg-eth0 and ifcfg-eth1. They are configured like below:
DEVICE=eth0
BOOTPROTO=ibft
HWADDR=B2:99:99:00:00:50
NM_CONTROLLED=no
ONBOOT=yes
 
5. Use the below advisory note,
http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c05235426&sp4ts.oid=1008615168

6. Then reboot the OS and edit the grub to add ifname=XX ip=YY information for both the ports as mentioned in the advisory note
ifname=eth0:b2:99:99:00:00:50 ip=10.1.0.27:::255.0.0.0::eth0:none
ifname=eth1:b2:99:99:00:00:52 ip=192.1.0.28:::255.0.0.0::eth1:none

7. While booting, the eth0 and eth1 interfaces are seen up and running and acquire information from iBFT table

8. The OS falls to dracut shell without switching the root and also does not kick-off the iscsistart script to login to the iSCSI targets
 
Actual results:
On first boot, the OS falls to dracut shell at the pre-pivot stage

Expected results:
The OS should kick-start the iscsistart script, login to the iSCSI targets and boot successfully.

Additional info:
1. within the dracut shell, login to iSCSI target using "iscsistart -b" is successful and upon exiting the dracut shell, the OS boots successfully. (attached screenshot)
2. It is observed that in the pre-pivot stage of OS boot, the OS fails to kick-off iscsistart and does not login to the iSCSI targets.
3. The OS boots successfully if only single path info is given on kernel cmdline at grub,
ifname=eth0:b2:99:99:00:00:50 ip=10.1.0.27:::255.0.0.0::eth0:none
4. The OS fails to boot if only second path info is given on kernel cmdline,
ifname=eth1:b2:99:99:00:00:52 ip=192.1.0.28:::255.0.0.0::eth1:none 
5. At the dracut shell, "ip addr show" shows that eth0 and eth1 interfaces have acquired correct information from the iBFT table and are UP. (attached screenshot)
Comment 2 Nilesh Javali 2017-08-01 03:10 EDT
Created attachment 1307393 [details]
DUD used to update drivers
Comment 3 Nilesh Javali 2017-08-01 03:11 EDT
Created attachment 1307394 [details]
iBFT info at dracut shell
Comment 4 Nilesh Javali 2017-08-01 03:12 EDT
Created attachment 1307395 [details]
eth0 and eth1 info at dracut shell
Comment 5 Nilesh Javali 2017-08-01 03:13 EDT
Created attachment 1307397 [details]
manual iscsistart login at dracut shell
Comment 6 Trinh Dao 2017-08-03 11:22:49 EDT
Nilesh, can you reproduce the issue with RHEL6.9GA?
Comment 7 Nilesh Javali 2017-09-18 02:57:17 EDT
The issue is not reproducible with RHEL 6.9.
Assigning to Girisha for re-confirmation.
Comment 8 Rob Evers 2017-11-15 19:31:55 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/
Comment 9 Rob Evers 2017-11-28 14:47:58 EST
If this issue can be reproduced and is 100% determined to be a regression, please re-open this.  As it stands now, niether are the case.

Note You need to log in before you can comment on or make changes to this bug.