Bug 1477120 - Openstack Ocata3 fails due to timeout error because of Nova-Scheduler EXIT code 1 (failure of this service start).
Openstack Ocata3 fails due to timeout error because of Nova-Scheduler EXIT co...
Status: NEW
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
Ocata
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: nlevinki
Prasanth Anbalagan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 05:30 EDT by kostyanius
Modified: 2017-08-04 10:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install error (66.51 KB, image/png)
2017-08-01 05:30 EDT, kostyanius
no flags Details

  None (edit)
Description kostyanius 2017-08-01 05:30:30 EDT
Created attachment 1307474 [details]
install error

Description of problem:
Openstack Ocata-3 install fails on Centos 7.3, RedHat 7.3, Scientific Linux 7.3.

Version-Release number of selected component (if applicable):


How reproducible:

Install OS (minimal install)
Follow this manual: https://www.rdoproject.org/install/packstack/

Steps to Reproduce:
1. Stop + delete all mentioned services in manual.
2. Run 'sudo packstack --allinone'
3. Check 'sudo journalctl -xe' and open install log to see the errors: 

Actual results:

Got many errors: 
Journalctl -xe: Failed to Start Nova Scheduler server
packstack output: ERROR: Error appeared during puppet run: 192.168.88.246_controller.pp
Error: /Stage[main]/Nova::Db::Sync/Exec[Nova-db-sync]: Failed to call refresh: Command exceeded timeout  
log file output: Failed to apply catalog: Command 'openstack ["flavor", "list", "--quiet", "--format", "csv", ["--long", "--all"]]' has been running for more than 40 seconds (tried 4 for total of 170 seconds" 

Expected results:
Install of Openstack without timeout error.

Additional info:
Used Hyper-V with 4 cores CPU, 8 Gb of RAM, 1 ext NIC.
Comment 1 kostyanius 2017-08-01 05:36:38 EDT
Tried many times with different variants of package installation (minimal install, server with gui) on Centos, RadHat with Developers subscription, amd Scientific Linux. All the time i am facinf with such an error. Have not managed to find workaround.
Tried:
1. Update from 2.7 python to 3.6 version.
2. Delete iptables, selinux with postfix.
3. Delete all listening sockets and programs which could interrupt Openstack installation.

Still no luck.
Comment 2 kostyanius 2017-08-02 23:39:34 EDT
Ocata Version: centos-release-openstack-ocata-1-2.el7.noarch
Comment 3 kostyanius 2017-08-02 23:49:16 EDT
I have already installed Openstack Ocata according to the following guide: https://www.rdoproject.org/install/packstack/ with VmWare Player 12.5.7 ver.
Installation has been passed without any issues from the first attempt.
So, looks like issue is only reproducible when use Hyper-V with Centos/RedHat/Scientific Linux as guest OS. Probably some additional configuration is needed for Hyper-V, e.g. like it is in VmWare player there is virtualization options but in Hyper-V there is no any.

Note You need to log in before you can comment on or make changes to this bug.