This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 147723 - Bad: Kernel panic
Bad: Kernel panic
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 14:57 EST by Markku Pakarinen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Pakarinen 2005-02-10 14:57:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Kernel 2.6.9-1.6_FC2 was the last working kernel version that work with my 
fc2. 
Next last one's folowing give kernel panic pointing to harddisks lock. 
Could'n add fc3. That gave me same result. So what can i do now ? Stuck with 
fc2. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Kernel 2.6.9-1.6_FC2 was the last working kernel version 
2.Next one's folowing give kernel panic pointing to harddisks lock 
3. 
   

Additional info:
Comment 1 Dave Jones 2005-02-10 15:47:02 EST
can you paste the exact panic text please ?
Comment 2 Markku Pakarinen 2005-02-18 15:30:14 EST
Can not copy/paste because of kernel panic, so i wrote it down and write it 
again here. 
 
Booting 'Fedore Core (2.6.10-1.14_FC2)' 
root (hd0,5) 
Filesystem type is ext2fs, partition type 0x83 
kernel /boot/vmlinuz-2.6.10-1.14_FC2 ro root=LABEL=/ rhgb quiet 
[Linux-bzImage, setup=0x1400, size=0x165f85] 
initrd /boot/initrd-2.6.10-1.14_FC2.img 
[Linux-initrd@0x1febd000, 0x32d1e bytes] 
 
Uncompressing Linux... Ok, booting the kernel. 
ACPI: Bios age (2000) fails cutoff (2001), acpi=force is required to enable 
ACPI 
audit (1108763442.760:0): initialized 
 
Kernel panic - not syncing: drivers/ide/pci/piix.c:232: 
  spin_lock(drivers/ide/ide.c:c037a5a8) already locked by 
   crivers/ide/ide-iops.c/1222 
 
That's it. Did not get last five kernel's to work with my computer !!! 
Look like that harddisk does'nt get sync ? Is this possible to fix ? 
Comment 3 Markku Pakarinen 2005-03-03 12:30:35 EST
Can not copy/paste because of kernel panic, so i wrote it down and write it  
again here.  
  
Booting 'Fedore Core (2.6.10-1.770_FC2)'  
root (hd0,5)  
Filesystem type is ext2fs, partition type 0x83  
kernel /boot/vmlinuz-2.6.10-1.770_FC2 ro root=LABEL=/ rhgb quiet  
[Linux-bzImage, setup=0x1400, size=0x165f4c]  
initrd /boot/initrd-2.6.10-1.770_FC2.img  
[Linux-initrd@0x1febe000, 0x31fd9 bytes]  
  
Uncompressing Linux... Ok, booting the kernel.  
ACPI: Bios age (2000) fails cutoff (2001), acpi=force is required to enable  
ACPI  
audit (1109877251.817:0): initialized  
  
Kernel panic - not syncing: drivers/ide/pci/piix.c:232:  
  spin_lock(drivers/ide/ide.c:c037a5a8) already locked by  
   crivers/ide/ide-iops.c/1222  
  
That's it. Did not get last six kernel's to work with my computer !!!  
Look like that harddisk does'nt get sync ? Is this possible to fix ?  
  
 
Comment 4 Markku Pakarinen 2005-03-29 13:43:45 EST
-Me myself. 
Well, I get it work when someone told me that add parameter "ide=nodma" to 
grub.conf. That slows down a little harddisks but must get come along with 
this. So now finally i got kernel 2.6.10-1.771_FC2 working. 
Comment 5 Dave Jones 2005-04-16 00:53:35 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.