Bug 1477258 - Upgrade from L->M fails on converge: Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron]
Upgrade from L->M fails on converge: Error: Must pass neutron_admin_password ...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 11:03 EDT by Yolanda Robla
Modified: 2017-08-02 04:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 04:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolanda Robla 2017-08-01 11:03:51 EDT
When executing the converge step, heat is failing with this error:

 Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/ed30356b-e1c5-4da1-b1d3-e987a18f039d.pp:174 on node overcloud-compute-0.localdomain\u001b[0m\n\u001b[1;31mError: Must pass neutron_admin_password to Class[Nova::Network::Neutron]


 openstack stack resource list         --nested-depth 5 overcloud | grep FAILED
| ControllerNodesPostDeployment                | 34e64f2d-2388-465c-80d4-261bf4815804          | OS::TripleO::ControllerPostDeployment                                           | UPDATE_FAILED   | 2017-08-01T14:13:18 | overcloud                                                                                                                                       |
| ControllerServicesBaseDeployment_Step2       | 210211ba-e88f-4e19-8987-c57546e721a3          | OS::Heat::StructuredDeployments                                                 | UPDATE_FAILED   | 2017-08-01T14:15:26 | overcloud-ControllerNodesPostDeployment-y2ujwmemz7ha                                                                                            |
| 0                                            | bae1df7b-9314-4a93-9d9f-f425047351eb          | OS::Heat::StructuredDeployment                                                  | CREATE_FAILED   | 2017-08-01T14:15:27 | overcloud-ControllerNodesPostDeployment-y2ujwmemz7ha-ControllerServicesBaseDeployment_Step2-3l45haovluky                                        |
| ComputeNodesPostDeployment                   | 325b8137-57fc-49c9-841a-421e9ccfe282          | OS::TripleO::ComputePostDeployment                                              | UPDATE_FAILED   | 2017-08-01T14:13:17 | overcloud                                                                                                                                       |
| ComputePuppetDeployment                      | 2f6260f7-7a5a-4b2f-861b-f449e4cefe76          | OS::Heat::StructuredDeployments                                                 | UPDATE_FAILED   | 2017-08-01T14:13:53 | overcloud-ComputeNodesPostDeployment-hvb2wem5qzkv                                                                                               |
| 0                                            | 151a08e6-a280-48f9-90ab-00c992edb460          | OS::Heat::StructuredDeployment                                                  | CREATE_FAILED   | 2017-08-01T14:13:54 | overcloud-ComputeNodesPostDeployment-hvb2wem5qzkv-ComputePuppetDeployment-ypzhdh3fl3oc                                                          |



heat deployment-show 151a08e6-a280-48f9-90ab-00c992edb460
WARNING (shell) "heat deployment-show" is deprecated, please use "openstack software deployment show" instead
{
  "status": "FAILED", 
  "server_id": "4a6f3712-a30a-4a53-8fca-929fb4762385", 
  "config_id": "38b03d8f-5ced-4843-b89e-eb6921fef465", 
  "output_values": {
    "deploy_stdout": "", 
    "deploy_stderr": "Could not retrieve fact='apache_version', resolution='<anonymous>': undefined method `[]' for nil:NilClass\nCould not retrieve fact='apache_version', resolution='<anonymous>': undefined method `[]' for nil:NilClass\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::host'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_protocol'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::port'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_path'; class ::nova::vncproxy has not been evaluated\u001b[0m\n\u001b[1;31mError: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/38b03d8f-5ced-4843-b89e-eb6921fef465.pp:174 on node overcloud-compute-0.localdomain\u001b[0m\n\u001b[1;31mError: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/38b03d8f-5ced-4843-b89e-eb6921fef465.pp:174 on node overcloud-compute-0.localdomain\u001b[0m\n", 
    "deploy_status_code": 1
  }, 
  "creation_time": "2017-08-01T14:13:55", 
  "updated_time": "2017-08-01T14:14:12", 
  "input_values": {
    "update_identifier": {
      "compute_config": {
        "0": "os-apply-config deployment 99d315e1-613d-4ce5-85f4-c24934073116 completed,Root CA cert injection not enabled.,None,"
      }, 
      "deployment_identifier": 1501595473, 
      "allnodes_extra": "none"
    }
  }, 
  "action": "CREATE", 
  "status_reason": "deploy_status_code : Deployment exited with non-zero status code: 1", 
  "id": "151a08e6-a280-48f9-90ab-00c992edb460"
}
Comment 1 Yolanda Robla 2017-08-01 11:27:31 EDT
Adding the openstack-puppet-modules i have:

compute-> 7.1.5-5.el7ost (still on latest 8)
controllers -> 8.1.13-3.el7ost (upgraded to 9)
undercloud -> 8.1.13-3.el7ost (upgraded to 9)
Comment 2 Yolanda Robla 2017-08-02 04:17:54 EDT
The compute node had not been upgraded properly, that was the reason of that failure.

Note You need to log in before you can comment on or make changes to this bug.