Bug 1477387 - nmap-7.60 is available
nmap-7.60 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nmap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 1477437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 20:20 EDT by Upstream Release Monitoring
Modified: 2017-08-03 07:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-03 05:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2017-08-01 20:20:30 EDT
Latest upstream release: 7.60
Current version/release in rawhide: 7.50-9.fc27
URL: http://nmap.org/dist/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/2096/
Comment 1 Upstream Release Monitoring 2017-08-01 20:20:36 EDT
One or more of the specfile's Sources is not a valid URL so we cannot automatically build the new version for you. Please use a URL in your Source declarations if possible.
Comment 2 Pavel Zhukov 2017-08-02 02:15:40 EDT
*** Bug 1477437 has been marked as a duplicate of this bug. ***
Comment 3 Upstream Release Monitoring 2017-08-02 02:51:40 EDT
landgraf's nmap-7.60-1.fc27 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=942741
Comment 4 Paul Howarth 2017-08-02 06:56:43 EDT
nmap 7.60 is now bundling libssh2 1.8.0 ...
Comment 5 Pavel Zhukov 2017-08-03 03:56:55 EDT
(In reply to Paul Howarth from comment #4)
> nmap 7.60 is now bundling libssh2 1.8.0 ...

as well as libz. Working on it.
Comment 6 Upstream Release Monitoring 2017-08-03 04:52:24 EDT
landgraf's nmap-7.60-3.fc27 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=946245
Comment 7 Pavel Zhukov 2017-08-03 05:12:52 EDT
nmap-7.60-4 built in rawhide. Bundled libraries were deleted (patch sent upstream). Sanity testing passed. Closing
Comment 8 Paul Howarth 2017-08-03 05:25:38 EDT
Not quite right:

$ nmap -V                                                                                                                                                   
Nmap version 7.60 ( https://nmap.org )                                                                                                             
Platform: x86_64-redhat-linux-gnu                                                                                                                  
Compiled with: liblua-5.3.4 openssl-1.0.2k libssh2-#LIBSSH2_VERSION libz-#LIBZ_VERSION libpcre-8.41 libpcap-1.7.4 nmap-libdnet-1.12 ipv6
Compiled without:
Available nsock engines: epoll poll select

Also, the s/$RPM_BUILD_ROOT/%{buildroot}/g changes in the changelog need the '%' character escaping with another '%' character, and there's one instance of '$%{buildroot}'.
Comment 9 Pavel Zhukov 2017-08-03 07:34:48 EDT
Yeah. It was not good idea to blindly change all RPM_BUILD_ROOT. I've excluded changelog now. 
Seems like we need patch for proper versioning information anyway (otherwise hardcoded version is displayed even if library is not bundled). 
https://github.com/nmap/nmap/pull/957

Should be fixed now:
# ./nmap -V

Nmap version 7.60 ( https://nmap.org )
Platform: x86_64-redhat-linux-gnu
Compiled with: liblua-5.3.3 openssl-1.1.0f libssh2-1.8.0 libz-1.2.11 libpcre-8.41 libpcap-1.8.1 nmap-libdnet-1.12 ipv6
Compiled without:
Available nsock engines: epoll poll select

Note You need to log in before you can comment on or make changes to this bug.