Bug 1477396 - Touchpad freezes after closing lid
Touchpad freezes after closing lid
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-01 20:42 EDT by Cesar
Modified: 2018-02-28 08:19 EST (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-28 08:19:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cesar 2017-08-01 20:42:05 EDT
Description of problem:
Touchpad isn't working after closing the lid. If I never close the lid, the touchpad works without problem.

Version-Release number of selected component (if applicable):
Fedora 26, in all published kernels


How reproducible:
Always

Steps to Reproduce:
1. Boot into Fedora
2. Close lid
3. Open lid (after some time, like, 1 minute)

Actual results:
Touchpad isn't working anymore

Expected results:
Touchpad working

Additional info:

Some dmesg listings:

[cesar@f1spirit ~]$ dmesg | grep -E '[sS]ynaptics|psmouse'
[    3.470274] psmouse serio1: synaptics: queried max coordinates: x [..5660], y [..4642]
[    3.564559] psmouse serio1: synaptics: queried min coordinates: x [1366..], y [1298..]
[    3.738866] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd40123/0x840300/0x126800/0x0, board id: 2934, fw id: 1541093
[    3.862429] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6
[   19.423239] rmi4_f01 rmi4-00.fn01: found RMI device, manufacturer: Synaptics, product: s3203, fw id: 1541093
[   19.480595] input: Synaptics s3203 as /devices/pci0000:00/INT33C3:00/i2c-8/i2c-DLL063E:00/0018:06CB:2934.0002/input/input14
[ 9213.092311] psmouse serio1: Failed to disable mouse on isa0060/serio1

Getting dmesg listing on lid closing/opening:

[cesar@f1spirit ~]$ dmesg | grep 921[1-4]
[ 9211.048701] PM: Syncing filesystems ... done.
[ 9212.912120] PM: Preparing system for sleep (mem)
[ 9212.912406] Freezing user space processes ... (elapsed 0.003 seconds) done.
[ 9212.915795] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 9212.917390] PM: Suspending system (mem)
[ 9212.917442] Suspending console(s) (use no_console_suspend to debug)
[ 9212.987065] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 9212.988075] sd 0:0:0:0: [sda] Stopping disk
[ 9213.092311] psmouse serio1: Failed to disable mouse on isa0060/serio1
[ 9213.492278] ACPI : EC: event blocked
[ 9214.038577] PM: suspend of devices complete after 1120.873 msecs
[ 9214.038579] PM: suspend devices took 1.121 seconds
[ 9214.050449] PM: late suspend of devices complete after 11.866 msecs
[ 9214.051014] ACPI : EC: interrupt blocked
[ 9214.051690] pcieport 0000:00:1c.0: System wakeup enabled by ACPI
[ 9214.051742] ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
[ 9214.051784] xhci_hcd 0000:00:14.0: System wakeup enabled by ACPI
[ 9214.075440] PM: noirq suspend of devices complete after 24.986 msecs
[ 9214.076030] ACPI: Preparing to enter system sleep state S3
[ 9214.076647] ACPI : EC: EC stopped
[ 9214.076649] PM: Saving platform NVS memory
[ 9214.076670] Disabling non-boot CPUs ...
[ 9214.077955] Cannot set affinity for irq 51
[ 9214.079045] smpboot: CPU 1 is now offline
[ 9214.082205] smpboot: CPU 2 is now offline
[ 9214.084317] smpboot: CPU 3 is now offline
[ 9214.087438] ACPI: Low-level resume complete
[ 9214.087550] ACPI : EC: EC started
[ 9214.087551] PM: Restoring platform NVS memory
[ 9214.087936] Suspended for 388.000 seconds
[ 9214.093215] Enabling non-boot CPUs ...
[ 9214.093285] x86: Booting SMP configuration:
[ 9214.093287] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 9214.095227]  cache: parent cpu1 should not be sleeping
[ 9214.095680] CPU1 is up
[ 9214.095729] smpboot: Booting Node 0 Processor 2 APIC 0x2
[ 9214.097046]  cache: parent cpu2 should not be sleeping
[ 9214.097198] microcode: sig=0x40651, pf=0x40, revision=0x1c
[ 9214.100150] microcode: updated to revision 0x20, date = 2017-01-27
[ 9214.100415] CPU2 is up
[ 9214.100452] smpboot: Booting Node 0 Processor 3 APIC 0x3
[ 9214.101709]  cache: parent cpu3 should not be sleeping
[ 9214.101857] microcode: sig=0x40651, pf=0x40, revision=0x20
[ 9214.102109] CPU3 is up
[ 9214.108874] ACPI: Waking up from system sleep state S3
[ 9214.110149] acpi LNXPOWER:01: Turning OFF
[ 9214.110409] ACPI : EC: interrupt unblocked
[ 9214.121846] ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
[ 9214.230780] xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
[ 9214.534759] PM: noirq resume of devices complete after 424.581 msecs
[ 9214.547891] PM: early resume of devices complete after 13.088 msecs
[ 9214.548091] ACPI : EC: event unblocked
[ 9214.548712] pcieport 0000:00:1c.0: System wakeup disabled by ACPI
[ 9214.548750] ath: phy0: ASPM enabled: 0x43
[ 9214.549238] sd 0:0:0:0: [sda] Starting disk
[ 9214.613744] ACPI : button: The lid device is not compliant to SW_LID.
[ 9214.613834] rtc_cmos 00:01: System wakeup disabled by ACPI
[ 9214.719979] r8169 0000:01:00.0 enp1s0: link down
[ 9214.770692] usb 1-1.8: reset high-speed USB device number 6 using ehci-pci
[ 9214.914749] usb 1-1.7: reset high-speed USB device number 5 using ehci-pci
Comment 1 Geoff Ericksson 2017-08-02 07:08:07 EDT
I have this problem too on 

kernel: 4.11.11-300.fc26.x86_64 
product: 80QE (LENOVO_MT_80QE_BU_idea_FM_Lenovo YOGA 700-11ISK)

Since the keyboard still works, I can use keyboard shortcuts to bring up a terminal and type the following workaround commands to restore functionality:

sudo modprobe -r i2c_hid
sudo modprobe i2c_hid
Comment 2 Cesar 2017-08-02 19:11:12 EDT
(In reply to Geoff Ericksson from comment #1)
> I have this problem too on 
> 
> kernel: 4.11.11-300.fc26.x86_64 
> product: 80QE (LENOVO_MT_80QE_BU_idea_FM_Lenovo YOGA 700-11ISK)
> 
> Since the keyboard still works, I can use keyboard shortcuts to bring up a
> terminal and type the following workaround commands to restore functionality:
> 
> sudo modprobe -r i2c_hid
> sudo modprobe i2c_hid

Yes, this workaround works for me too. And looking on dmesg...

[cesar@f1spirit ~]$ dmesg | grep .hid
(after opening the lid)
[15445.732803] hid-rmi 0018:06CB:2934.0005: rmi_hid_read_block: timeout elapsed
[15446.756793] hid-rmi 0018:06CB:2934.0005: rmi_hid_read_block: timeout elapsed
[15447.780780] hid-rmi 0018:06CB:2934.0005: rmi_hid_read_block: timeout elapsed
[15448.804769] hid-rmi 0018:06CB:2934.0005: rmi_hid_read_block: timeout elapsed
[15449.828759] hid-rmi 0018:06CB:2934.0005: rmi_hid_read_block: timeout elapsed
[15449.828779] dpm_run_callback(): i2c_hid_resume+0x0/0xe0 [i2c_hid] returns -11
(run the workaround)
[15486.357703] hid-rmi 0018:06CB:2934.0006: input,hidraw1: I2C HID v1.00 Pointer [DLL063E:00 06CB:2934] on i2c-DLL063E:00
Comment 3 Laura Abbott 2018-02-27 22:52:32 EST
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.
Comment 4 Cesar 2018-02-28 07:32:05 EST
It was solved in one of those kernel updates, don't remember when. Bug can be closed!
Comment 5 Benjamin Tissoires 2018-02-28 08:19:41 EST
Thanks for the notice (and sorry for not answering earlier)!

Note You need to log in before you can comment on or make changes to this bug.