Bug 147759 - gnome-volume-control SEGV
gnome-volume-control SEGV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-10 18:49 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 05:17:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-02-10 18:49:03 EST
(gnome-volume-control:31341): Gtk-CRITICAL **: gtk_table_set_row_spacing:
assertion `row < table->nrows' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 805667200 (LWP 31341)]
0x0fc2b1c4 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x0fc2b1c4 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#1  0x0fc2b1a8 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#2  0x10005f40 in gnome_volume_control_element_change (el=0x1012c020,
    element=0xfd11e7c) at element.c:379
#3  0x100060fc in gnome_volume_control_element_new (element=0x100d9320,
    client=0x100c9508, appbar=0x1011df60) at element.c:111
#4  0x10009fe4 in gnome_volume_control_window_new (elements=0x100e3458)
    at window.c:235
#5  0x10006784 in main (argc=0, argv=0x44004822) at main.c:265
(gdb) up 2
#2  0x10005f40 in gnome_volume_control_element_change (el=0x1012c020,
    element=0xfd11e7c) at element.c:379
379         update_tab_visibility (el, i);

Comment out the offending line 379 and it does manage to start up. Play with the
config a bit, enabling display of other levels than the default two, and it
crashes again.

(gnome-volume-control:31683): Gtk-CRITICAL **: gtk_table_set_row_spacing:
assertion `row < table->nrows' failed

(gnome-volume-control:31683): Gtk-CRITICAL **: gtk_table_set_row_spacing:
assertion `row < table->nrows' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 805667200 (LWP 31683)]
0x0fc2b1c4 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x0fc2b1c4 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#1  0x0fc2b1a8 in gtk_widget_show () from /usr/lib/libgtk-x11-2.0.so.0
#2  0x0f6a8e58 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#3  0x0f695184 in gconf_listeners_notify () from /usr/lib/libgconf-2.so.4
#4  0x0f6a8fa8 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#5  0x0f6a925c in gconf_client_notify () from /usr/lib/libgconf-2.so.4
#6  0x0f0c42a0 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#7  0x0f0c0118 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#8  0x0f0c22ec in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#9  0x0f0c2714 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x0fb188dc in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x10006714 in main (argc=269793944, argv=0x1012c020) at main.c:268
Comment 1 Colin Charles 2005-07-22 09:29:59 EDT
Looks like it's fixed in rawhide - gnome-media-2.11.5-1.ppc.rpm doesn't seem to
exhibit a SEGV.
Comment 2 Bastien Nocera 2007-02-02 05:17:10 EST
Closing, as it's been fixed a while ago.

Note You need to log in before you can comment on or make changes to this bug.