Bug 1477614 - [RFE] You should be able to manually unlock a luks device and then do the partitioning from the gui installer
[RFE] You should be able to manually unlock a luks device and then do the par...
Status: NEW
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: blivet-maint-list@redhat.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 09:26 EDT by Peter Gervase
Modified: 2017-08-03 06:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gervase 2017-08-02 09:26:09 EDT
Description of problem:
As mentioned in bug 1477351, I have some issues with the installer and my vg. For troubleshooting that, I tried manually unlocking the luks device, mounting, ... making sure the volgroup was OK. After that, I went into the graphical installer and tried to configure partitioning. When I did that, I again had to enter the luks password for my encrypted drive. However, when I entered the password, I got an error, "Failed to activate device: Device or resource busy"

The installer should see that the encrypted device has already been unlocked and then not prompt you for the password to unlock it. 

Version-Release number of selected component (if applicable):
rawhide, netinstall iso from 2017-Jul-31 05:53:01 

How reproducible:
100%

Steps to Reproduce:
1. Have an encrypted drive
2. Boot up from an iso to install
3. control + alternate + f3 to get to a console
4. manually unlock your encrypted drive
5. mount one of the drives from there
6. Go back into the installer
7. Try to configure partitioning.

Actual results:
It will error after you enter the luks password in the graphical installer.

Expected results:
The installer should see that the encrypted drive has already been unlocked.

Additional info:
Comment 1 Jiri Konecny 2017-08-03 06:04:25 EDT
I guess this needs to be changed in blivet library. I guess they could look if the device is already unlocked and then ignore this unlocking attempt from Anaconda.

Note You need to log in before you can comment on or make changes to this bug.