Bug 1477649 - Horizon quota settings missing the gigabytes quota
Horizon quota settings missing the gigabytes quota
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila-ui (Show other bugs)
10.0 (Newton)
Unspecified Linux
low Severity low
: z6
: 10.0 (Newton)
Assigned To: Tom Barron
Dustin Schoenbrun
: TestOnly, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 10:29 EDT by stphilli
Modified: 2017-10-10 14:08 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-manila-ui-2.5.1-9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-10 14:08:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the horizon quotas page (123.45 KB, image/png)
2017-08-02 10:29 EDT, stphilli
no flags Details
Output of openstack quota show (1.92 KB, text/plain)
2017-08-30 11:35 EDT, Dustin Schoenbrun
no flags Details
Screenshot of Horizon UI showing quotas (116.08 KB, image/png)
2017-08-30 11:36 EDT, Dustin Schoenbrun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3188292 None None None 2017-09-18 15:00 EDT
OpenStack gerrit 482572 None None None 2017-08-04 12:20 EDT

  None (edit)
Description stphilli 2017-08-02 10:29:13 EDT
Created attachment 1308271 [details]
Screenshot of the horizon quotas page

Description of problem:
In the Horizon client for RHOSP 10 there is no option to set a disk space related quota, the only disk related quota available in Horizon is for setting the number of Cinder volumes allowed. Via the cli you can see that a gigabytes quota exists in the output of "openstack quota show"

Version-Release number of selected component (if applicable):
Tested this in versions 10 and 11 

How reproducible:
Extremely reproducible

Steps to Reproduce:
1.Launch horizon
2.Identity -> Projects -> try to set a quota on a project


Actual results:
No disk space(gigabytes) quota
Comment 1 Radomir Dopieralski 2017-08-02 17:20:41 EDT
I couldn't reproduce this on my packstack installation, I suspect this is a configuration issue with the director-based installations. I'm going to try and investigate that.
Comment 2 stphilli 2017-08-02 17:26:27 EDT
Both of the environments I tested this on were director based installs
Comment 3 Radomir Dopieralski 2017-08-03 08:59:47 EDT
I have narrowed the problem down to the manilla dashboard plugin -- with that plugin disabled the fields are visible. I'm continuing the investigation.
Comment 4 Radomir Dopieralski 2017-08-03 09:08:02 EDT
Looks like manila also has quota fields named "gigabytes" and "snapshot", and it monkey-patches Horizon to disable quota fields with such names globally if the "share" service is not available.
Comment 11 Dustin Schoenbrun 2017-08-30 11:35 EDT
Created attachment 1320177 [details]
Output of openstack quota show
Comment 12 Dustin Schoenbrun 2017-08-30 11:36 EDT
Created attachment 1320178 [details]
Screenshot of Horizon UI showing quotas
Comment 14 Lon Hohberger 2017-09-06 15:56:36 EDT
According to our records, this should be resolved by openstack-manila-ui-2.5.1-9.el7ost.  This build is available now.

Note You need to log in before you can comment on or make changes to this bug.