Bug 1477772 - upgrade from rpcbind-0.2.0-38.el7_3.1.x86_64 to rpcbind-0.2.0-42.el7.x86_64 reintroduces crash of rpcbind
upgrade from rpcbind-0.2.0-38.el7_3.1.x86_64 to rpcbind-0.2.0-42.el7.x86_64 r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.4
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-02 17:48 EDT by Andy Feldt
Modified: 2017-09-14 08:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-14 08:39:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Feldt 2017-08-02 17:48:05 EDT
Description of problem:
When updating from RHEL 7.3 to 7.4, rpcbind is also updated and the new version appears to reintroduce a crash of rpcbind fairly soon after startup in our NFS/NIS environment.

Version-Release number of selected component (if applicable):
0.2.0-42.el7.x86_64

How reproducible:
Every time after upgrade to RHEL 7.4, rpcbind crashes and NIS and NFS fail.

Steps to Reproduce:
1. Boot system
2. Wait less than 10 minutes typically
3. rpcbind will fail

Actual results:
rpcbind fails

Expected results:
rpcbind continues

Additional info:
Downgrading to 0.2.0-38.el7_3.1.x86_64 corrects the problem.  This must be done on both the NFS/NIS servers and clients.
Comment 2 Andy Feldt 2017-09-13 11:59:36 EDT
A recent test shows that this is no longer an issue.  I have updated multiple components since then (including the kernel) and so I do not know which caused the problem to no longer exist.  In any case I will close this bug.
Comment 3 Steve Dickson 2017-09-14 08:39:55 EDT
(In reply to Andy Feldt from comment #2)
> A recent test shows that this is no longer an issue.  I have updated
> multiple components since then (including the kernel) and so I do not know
> which caused the problem to no longer exist.  In any case I will close this
> bug.

Thank you for your testing!

Note You need to log in before you can comment on or make changes to this bug.