Bug 14779 - Perl IO:;Socket Timeout Broken
Summary: Perl IO:;Socket Timeout Broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
: 14863 14990 15199 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-28 05:07 UTC by Thornton Prime
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 19:18:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thornton Prime 2000-07-28 05:07:26 UTC
Perl won't create an IO socket with a timeout value. This totally breaks
Net::LDAP. I suspect a lot of other CPAN modules are going to be seriously
broken also by this.

Example:

  use Data::Dumper;
  use IO::Socket;

  $test = new IO::Socket::INET(           
	PeerAddr => 'www.redhat.com',
	PeerPort => 80,
	Proto => 'tcp',
	Timeout => 120
	);

  print Dumper($test);

Will produce 'undef'. Same code without the timeout line works fine. This
works fine with RedHat 6.2/Perl 5.00503.

Comment 1 Nalin Dahyabhai 2000-07-31 19:18:26 UTC
*** Bug 14863 has been marked as a duplicate of this bug. ***

Comment 2 Nalin Dahyabhai 2000-07-31 19:21:14 UTC
This should be fixed in perl-5.6.0-7 and later.  Please reopen this
bug ID if you find that this is not the case.

Comment 3 Nalin Dahyabhai 2000-08-03 11:39:43 UTC
*** Bug 14990 has been marked as a duplicate of this bug. ***

Comment 4 Nalin Dahyabhai 2000-08-03 11:41:12 UTC
*** Bug 15199 has been marked as a duplicate of this bug. ***

Comment 5 Nalin Dahyabhai 2000-08-03 11:41:25 UTC
*** Bug 14990 has been marked as a duplicate of this bug. ***

Comment 6 Nalin Dahyabhai 2000-08-03 11:41:48 UTC
*** Bug 14990 has been marked as a duplicate of this bug. ***

Comment 7 Nalin Dahyabhai 2000-08-03 11:42:25 UTC
*** Bug 14990 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.