Bug 1477936 - Rebuild Docker Image devtoolset-7-toolchain-rhel7 for Beta
Rebuild Docker Image devtoolset-7-toolchain-rhel7 for Beta
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-7-toolchain-docker (Show other bugs)
DTS 7.0 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 7.0
Assigned To: Marek Polacek
Miloš Prchlík
Vladimír Slávik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 05:27 EDT by Marek Polacek
Modified: 2017-10-24 06:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: devtoolset-7-toolchain-docker-7-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-24 06:40:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Polacek 2017-08-03 05:27:46 EDT
This is a DTS7 variant of #1378360.  Not sure what/if --repo-url I should use.
Comment 2 Marek Polacek 2017-08-03 05:31:14 EDT
Also, I think I've made the mistake and selected this image as a base image, while it should be layered.
Comment 3 Marek Polacek 2017-08-03 06:41:37 EDT
The image looks ok:

$ docker load -i docker-image-sha256_d227b96747282ff458f4a2464862f51aea8ee051cce2bc4d99acff0f62ee11b5.x86_64.tar.gz 
db5339f31bc7: Loading layer 205.9 MB/205.9 MB
5de1b1633474: Loading layer 10.24 kB/10.24 kB
dc194aea278d: Loading layer 198.7 MB/198.7 MB
Loaded image: mpolacek/devtoolset-7-toolchain-docker:devtoolset-7.0-rhel-7-docker-candidate-11253-20170803085826

$ docker run -i -t 0250def32ede gcc --version
gcc (GCC) 7.1.1 20170526 (Red Hat 7.1.1-2)
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Comment 4 Marek Polacek 2017-08-04 03:15:30 EDT
We'll still need qa_ack+.
Comment 6 Miloš Prchlík 2017-10-06 04:20:16 EDT
Verified with rhscl-beta/devtoolset-7-toolchain-rhel7:7-3.
Comment 8 errata-xmlrpc 2017-10-24 06:40:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3043

Note You need to log in before you can comment on or make changes to this bug.