Bug 1477941 - Live CD hangs when using GTX1070. Unable to install
Live CD hangs when using GTX1070. Unable to install
Status: NEW
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 05:40 EDT by 7oxicshadow
Modified: 2017-08-03 18:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Text Screen With Cursor (4.04 MB, image/jpeg)
2017-08-03 05:40 EDT, 7oxicshadow
no flags Details

  None (edit)
Description 7oxicshadow 2017-08-03 05:40:13 EDT
Created attachment 1308671 [details]
Text Screen With Cursor

Description of problem:

I am currently trying to install Fedora 26 using a live CD (Workstation).

It takes approx 5 minutes to get to a point where a mouse cursor is present on screen BUT the boot text is still shown behind. The mouse cursor will move, then freeze for ~15 seconds and then move again (repeating).

The last text entry was:

"Starting User Manager for UID 1000..."

At this point the Live CD is stuck and progresses no further.

I have validated to the Boot CD is not corrupted and the self check reports as PASS.

History (This is not new):

When I tried to do a fresh install of Fedora 25 I could get to the GUI using a boot CD but the mouse freezing issue was still present (Every 2 seconds for minutes at a time). It took me approx 2 hours to navigate the installer to get it to complete.

Once it installed everything works fine and runs at full speed with no issues?

I am guessing it is either related to the GTX1070 or the i7 6700K as they are the only things that I have updated?

My previous setup was a i7-970 with a GTX770 and I never experience any issues.


Version-Release number of selected component (if applicable):
Fedora 26 

How reproducible:
Fails every time

Steps to Reproduce:
1. Boot From Live CD

Actual results:
Hangs at text screen with mouse cursor

Expected results:
GUI to allow installation

Additional info:

i7 6700K @ 4.5GHz
16GB Ram
NVIDIA GTX1070
Using a USB DVD ROM drive to install (NON UEFI)
Dual Monitor Setup (With a third HDMI connection to a Yamaha HTR-2866 AMP)
Note: Monitors are connected using HDMI to DVI convertors
Comment 1 7oxicshadow 2017-08-03 18:47:43 EDT
I have managed to work around this bug but I was a real pain.

First, I made a mistake in my previous comment. I am using 2 "display port" connectors ( using cheap ebay Display Port to DVI converters (With a third HDMI connection to a Yamaha HTR-2866 AMP) )

I removed the GTX1070 and used the onboard Intel graphics to get Fedora 26 installed using the live cd.

After installing I put the GTX1070 back into the computer and booted. Part way through the boot process it hung with the following messages:

nouveau 0000:01:00.0: priv: HUB0: 00d054 00000007 (19408216)
nouveau 0000:01:00.0: DRM: Pointer to flat panel table invalid
nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22

I removed the 2 display port connectors from the GTX1070 and connected the HDMI only to a cheap Eyoyo (1280x800) monitor. This allowed me to get to a desktop (even with the errors mentioned above).

When I was at the desktop I had the mouse freezing issue that I mentioned in the initial post. After much patience I managed to download the latest NVIDIA drivers and forced a command line using the following command:

systemctl set-default muti-user.target.

After restarting I was now at a command prompt.

I successfully disabled nouveau in Grub and installed the NVIDIA binary driver.

I ran the following command(s):

systemctl set-default graphical.target
shutdown now

I reconnected my 2 display ports and original HDMI lead and rebooted.

Now everything works and my desktop is back to normal again.

It appears that whatever the issue is, it is related to nouveau and the GTX1070 (especially the display port connectors).

Note You need to log in before you can comment on or make changes to this bug.