Bug 1477970 - [abrt] meld: after_text_insert_text(): filediff.py:774:after_text_insert_text:TypeError: Argument 2 does not allow None as a value
[abrt] meld: after_text_insert_text(): filediff.py:774:after_text_insert_text...
Status: CLOSED DUPLICATE of bug 1513393
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:bf1a431c838ec57d80f8ad4af72...
:
: 1515380 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 07:08 EDT by Gergely Polonkai
Modified: 2017-12-01 06:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-01 06:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (762 bytes, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: cgroup (355 bytes, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: cpuinfo (1.34 KB, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: environ (1.38 KB, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: mountinfo (3.71 KB, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: namespaces (102 bytes, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details
File: open_fds (1.63 KB, text/plain)
2017-08-03 07:08 EDT, Gergely Polonkai
no flags Details

  None (edit)
Description Gergely Polonkai 2017-08-03 07:08:25 EDT
Version-Release number of selected component:
meld-3.17.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/meld --output=app/app/models.py ./app/app/models_LOCAL_32172.py ./app/app/models_BASE_32172.py ./app/app/models_REMOTE_32172.py
crash_function: after_text_insert_text
exception_type: TypeError
executable:     /usr/bin/meld
kernel:         4.11.11-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
filediff.py:774:after_text_insert_text:TypeError: Argument 2 does not allow None as a value

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/meld/filediff.py", line 774, in after_text_insert_text
    starting_at = buf.get_iter_at_mark(start_mark).get_line()
TypeError: Argument 2 does not allow None as a value

Local variables in innermost frame:
start_mark: None
textlen: 101
newtext: '        from gt2_games.event import GameEventSchema\n        from gt2_games.exc import EventLoadError\n'
it: <Gtk.TextIter object at 0x7fb4580245e8 (GtkTextIter at 0x5596955e5f70)>
buf: <meldbuffer.MeldBuffer object at 0x7fb4594c4ca8 (MeldBuffer at 0x7fb46400ba00)>
self: <filediff.FileDiff object at 0x7fb4594bad38 (FileDiff at 0x5596948552c0)>
Comment 1 Gergely Polonkai 2017-08-03 07:08:30 EDT
Created attachment 1308683 [details]
File: backtrace
Comment 2 Gergely Polonkai 2017-08-03 07:08:32 EDT
Created attachment 1308684 [details]
File: cgroup
Comment 3 Gergely Polonkai 2017-08-03 07:08:33 EDT
Created attachment 1308685 [details]
File: cpuinfo
Comment 4 Gergely Polonkai 2017-08-03 07:08:35 EDT
Created attachment 1308686 [details]
File: environ
Comment 5 Gergely Polonkai 2017-08-03 07:08:37 EDT
Created attachment 1308687 [details]
File: mountinfo
Comment 6 Gergely Polonkai 2017-08-03 07:08:38 EDT
Created attachment 1308688 [details]
File: namespaces
Comment 7 Gergely Polonkai 2017-08-03 07:08:40 EDT
Created attachment 1308689 [details]
File: open_fds
Comment 8 Wim ten Have 2017-11-20 12:34:31 EST
*** Bug 1515380 has been marked as a duplicate of this bug. ***
Comment 9 Dominic Hopf 2017-12-01 06:17:32 EST

*** This bug has been marked as a duplicate of bug 1513393 ***

Note You need to log in before you can comment on or make changes to this bug.