Bug 1478055 - gives no progress info on update/upgrade to fedora 26
gives no progress info on update/upgrade to fedora 26
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 09:49 EDT by udo
Modified: 2017-08-09 10:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 10:32:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2017-08-03 09:49:46 EDT
Description of problem:
While upgrading from fedora 24 to fedora 26 on my i686 Epia box (cting as firewall, so runs in 3 most of the time) I noticed that after the `dnf system-upgrade reboot` the system comes up and sits at

(...)
reached target system initialization
reached  system upgrade
reached system update

But nothing else happens w.r.t. to any progress messages. It just sat there.
Only the harddisk whirring could be an indication of anything happening.
After a while the box starts to reboot but no progress is not really helpful.

Version-Release number of selected component (if applicable):
dnf-1.1.10-4.fc24.noarch


How reproducible:
Upgrade from fedora 24 to fedora 26 using `dnf system-upgrade download --releasever=26 --allowerasing`


Expected results:
Progress during installation, upgrade, etc.

Additional info:
The x86_64 MythTV box that I upgraded but not really watch did show some progress stuff. So why the difference?
Comment 1 udo 2017-08-04 09:56:10 EDT
Also on this very x86_64 F24 that was upgraded to f26 no progress was shown after very similar bootup messages.
The whole operation lasted 2 hours so this is not very practical for the average user.
Comment 2 Jaroslav Mracek 2017-08-09 10:32:29 EDT
I am sorry but I am unable to reproduce it using dnf-plugin-system-upgrade-2.0.1 from dnf-nightly repository (dnf copr enable rpmsoftwaremanagement/dnf-nightly). But I tested it using upgrade from Fedore 25 to 26. Please if you will be able to reproduce it with fully upgraded Fedora 25 using dnf system-upgrade version 2.0.1+ don't hesitate to reopen the bug report.
Comment 3 udo 2017-08-09 10:38:10 EDT
I noticed this on two F24 systems.
I have one F25 system around but this one has issues with network interfaces so I am unsure if I can make things work.
How can a closed bug help improve rawhide quality?
Comment 4 Jaroslav Mracek 2017-08-09 10:46:10 EDT
I am sorry, that the tag was confusing. It means that the issue is solved in F26 and rawhide where fixed dnf and plugins were released. Therefore I am changing the tag. I guess that your problem was related to some services that are using during reboot to show progress. But as I said, the issue is solved with latest packages version of F25 + dnf-2.+

Note You need to log in before you can comment on or make changes to this bug.