Bug 1478083 - unable to rollback more than once
unable to rollback more than once
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm-ostree-client (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathan Lebon
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-03 10:30 EDT by Micah Abbott
Modified: 2017-09-05 09:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 09:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github projectatomic/rpm-ostree/issues/906 None None None 2017-08-08 09:18 EDT

  None (edit)
Description Micah Abbott 2017-08-03 10:30:23 EDT
From upstream issue:  https://github.com/projectatomic/rpm-ostree/issues/906


While working with some internal RHELAH composes, I found myself in a situation where I was unable to rollback more than one time.

RHELAH has `ostree-2017.7-1.el7.x86_64` and `rpm-ostree-client-2017.6-5.atomic.el7.x86_64`

```
# rpm-ostree status
State: idle
Deployments:
● rhelah-autobuild:rhel-atomic-host/7.4/x86_64/autobrew/buildmaster
                Version: 7.4.internal.0.24 (2017-08-02 15:22:41)
                 Commit: dafe417296e5e70533c6cd24d54ca59bdf8135915fb9a6930f1aa2f9a6fe06e5

  rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-07-28 00:26:01)
                 Commit: 846fb0e18e65bd9a62fc9d952627413c6467c33c2d726449a1d7ad7690bbb93a
           GPGSignature: 1 signature
                         Signature made Fri 28 Jul 2017 12:30:19 AM UTC using RSA key ID 199E2F91FD431D51
                         Good signature from "Red Hat, Inc. <security@redhat.com>"

# rpm-ostree rollback
Moving '846fb0e18e65bd9a62fc9d952627413c6467c33c2d726449a1d7ad7690bbb93a.0' to be first deployment
Transaction complete; bootconfig swap: yes deployment count change: 0
Downgraded:
  cockpit-bridge 147-1.el7 -> 138-9.el7
  cockpit-docker 147-1.el7 -> 141-4.el7
  cockpit-ostree 147-1.el7 -> 141-2.el7
  cockpit-system 147-1.el7 -> 138-9.el7
  docker 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  docker-client 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  docker-client-latest 1.13.1-22.git28ae36d.el7 -> 1.13.1-21.1.gitcd75c68.el7
  docker-common 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  docker-latest 1.13.1-22.git28ae36d.el7 -> 1.13.1-21.1.gitcd75c68.el7
  docker-lvm-plugin 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  docker-novolume-plugin 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  docker-rhel-push-plugin 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
  glusterfs 3.8.4-18.6.el7 -> 3.8.4-18.4.el7
  glusterfs-client-xlators 3.8.4-18.6.el7 -> 3.8.4-18.4.el7
  glusterfs-fuse 3.8.4-18.6.el7 -> 3.8.4-18.4.el7
  glusterfs-libs 3.8.4-18.6.el7 -> 3.8.4-18.4.el7
  gomtree 0.4.0-1.1.el7 -> 0.3.1-2.1.el7
  oci-register-machine 1:0-3.12.gitcbf1b8f.el7 -> 1:0-3.11.1.gitdd0daef.el7
  oci-systemd-hook 1:0.1.8-5.1.git1e84754.el7 -> 1:0.1.8-4.1.gite533efa.el7
  oci-umount 2:1.12.6-50.git0fdc778.el7 -> 2:1.12.6-48.git0fdc778.el7
Run "systemctl reboot" to start a reboot

# rpm-ostree status
State: idle
Deployments:
  rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-07-28 00:26:01)
                 Commit: 846fb0e18e65bd9a62fc9d952627413c6467c33c2d726449a1d7ad7690bbb93a
           GPGSignature: 1 signature
                         Signature made Fri 28 Jul 2017 12:30:19 AM UTC using RSA key ID 199E2F91FD431D51
                         Good signature from "Red Hat, Inc. <security@redhat.com>"

● rhelah-autobuild:rhel-atomic-host/7.4/x86_64/autobrew/buildmaster
                Version: 7.4.internal.0.24 (2017-08-02 15:22:41)
                 Commit: dafe417296e5e70533c6cd24d54ca59bdf8135915fb9a6930f1aa2f9a6fe06e5

# rpm-ostree rollback
error: No rollback deployment found
```

Reproducer:
1.  Boot RHELAH 7.4
2.  Rebase onto internal 'autobrew' stream
3.  Reboot
4.  Rollback to 7.4
5.  Attempt to rollback again to 'autobrew'
Comment 2 Jonathan Lebon 2017-08-03 10:35:19 EDT
https://github.com/projectatomic/rpm-ostree/pull/907
Comment 4 Micah Abbott 2017-08-17 12:21:16 EDT
This is fixed in rpm-ostree-client-2017.6-6.atomic.el7.x86_64
Comment 6 errata-xmlrpc 2017-09-05 09:55:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2631

Note You need to log in before you can comment on or make changes to this bug.