Bug 1478329 - boost ticket 12748: Boost.Test defines a variable called VERSION
boost ticket 12748: Boost.Test defines a variable called VERSION
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
26
All Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jonathan Wakely
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 06:39 EDT by Miroslav Franc
Modified: 2017-08-13 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: boost-1.63.0-6.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-13 16:53:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Franc 2017-08-04 06:39:32 EDT
As stated in the boost ticket, boost-test in boost 1.63 introduced a variable called "VERSION" which clashes with macro "VERSION" from config.h generated by autotools.  Would it be possible to backport the following fix to Fedora 26?  It seems to be fixed in boost 1.64.

https://svn.boost.org/trac10/ticket/12748

https://github.com/boostorg/test/commit/20bcf731e21f5b19b30d1b971fefaa3a0f2aba16

I solved this problem on my development machine simply by editing the offending boost header manually, but obviously that's not gonna work for anybody else trying to build our software on Fedora 26.  Another obvious workaround is to stick "#undef VERSION" before including that boost header, which is an ugly workaround and which I would like to avoid if possible.


Version-Release number of selected component (if applicable):
# rpm -q boost-devel
boost-devel-1.63.0-5.fc26.x86_64
Comment 1 Jonathan Wakely 2017-08-09 13:47:24 EDT
That's a pretty silly design error in Boost.Test, but I'm concerned about backporting the whole patch. Those variables are part of the public API of the library, e.g. LOG_LEVEL is documented at http://www.boost.org/doc/libs/1_63_0/libs/test/doc/html/boost_test/test_output/logging_api/log_ct_log_level.html

I think we can safely rename VERSION, because that seems to be for internal use only.
Comment 2 Miroslav Franc 2017-08-09 16:25:33 EDT
(In reply to Jonathan Wakely from comment #1)
Anything you can do would be appreciated.  It's just the "VERSION" variable causing the problems.  There's definitely no need to backport the whole thing.
Comment 3 Jonathan Wakely 2017-08-09 16:40:19 EDT
boost-1.63.0-6.fc26 is building now:
https://koji.fedoraproject.org/koji/buildinfo?buildID=953604
Comment 4 Fedora Update System 2017-08-13 00:04:30 EDT
boost-1.63.0-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-019deba4e2
Comment 5 Fedora Update System 2017-08-13 16:53:49 EDT
boost-1.63.0-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.