Bug 1478364 - kill passenger threads that have not returned in 60 minutes
Summary: kill passenger threads that have not returned in 60 minutes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.2.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-04 12:45 UTC by Chris Duryee
Modified: 2019-08-12 14:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-28 19:35:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 19243 0 None None None 2017-08-04 12:45:19 UTC
Red Hat Bugzilla 1452772 0 unspecified CLOSED [RFE] Passenger graceful killer cron job 2021-02-22 00:41:40 UTC

Internal Links: 1452772

Description Chris Duryee 2017-08-04 12:45:20 UTC
Description of problem:

Users occasionally hit bugs where the passenger process does not return for hours. While these bugs are serious and need to be addressed, it would be better for the Satellite if we just killed the process after some number of minutes instead of waiting forever.

It would be good if this setting is configurable via custom-hiera.yaml, and if information about the request (url, http action, params, stack trace) is logged when the process is killed.

Version-Release number of selected component (if applicable): 6.2.10

Steps to Reproduce:
1. make an API call that takes an extremely long time to return, or add a sleep statement to induce this behavior

Actual results: The request will eventually return, even after hours. During this time, the passenger processes is not accepting requests.

Expected results: Passenger process gives up after one hour


Additional info: I chose 60 minutes as a high first step since users occasionally run extremely long-running hammer commands. These long-running commands should not take as long, but we can work on lowering the 60 minute threshold as we fix issues.

Comment 7 Bryan Kearney 2019-02-07 12:09:29 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 8 Bryan Kearney 2019-02-28 19:35:07 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.