Bug 1478501 - wireshark-devel uninstallable due to addition of epoch to version
wireshark-devel uninstallable due to addition of epoch to version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
27
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Sehnoutka
Fedora Extras Quality Assurance
:
: 1478992 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-04 13:20 EDT by Daniel Berrange
Modified: 2017-08-16 06:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 06:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2017-08-04 13:20:18 EDT
Description of problem:
For reasons I don't understand, the latest build 2.4.0-5 added an "Epoch: 1" tag to the spec.

All the sub-packages have "Requires: wireshark = %{version}" which is now unresolvable, because 'wireshark' has an epoch.

eg

https://kojipkgs.fedoraproject.org//work/tasks/9731/21039731/root.log

   DEBUG util.py:439:  Error: nothing provides wireshark = 2.4.0-5.fc27 needed by wireshark-devel-1:2.4.0-5.fc27.x86_64

Since packages are forbidden to go backends in version, you can't remove this pointless epoch tag, so you'll need to change the deps to

Requires: wireshark = %{epoch}:%{version}"


Version-Release number of selected component (if applicable):
wireshark-1:2.4.0-5
Comment 1 Martin Sehnoutka 2017-08-07 03:27:30 EDT
Thanks for your report. The Epoch tag was introduces because I had to go backwards in version.
Comment 2 Martin Sehnoutka 2017-08-08 03:45:32 EDT
*** Bug 1478992 has been marked as a duplicate of this bug. ***
Comment 3 Jan Kurik 2017-08-15 05:35:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 4 Martin Sehnoutka 2017-08-16 06:09:25 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.