Bug 1478629 - [abrt] python3-qtconsole: qt_loaders.py:309:load_qt:ImportError:
[abrt] python3-qtconsole: qt_loaders.py:309:load_qt:ImportError:
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: python-qtconsole (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:30a0f2cbbaa3e89c5502e535d66...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-05 06:59 EDT by mov_ebpesp
Modified: 2017-12-12 05:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-12 05:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.77 KB, text/plain)
2017-08-05 06:59 EDT, mov_ebpesp
no flags Details
File: environ (1.26 KB, text/plain)
2017-08-05 06:59 EDT, mov_ebpesp
no flags Details

  None (edit)
Description mov_ebpesp 2017-08-05 06:59:52 EDT
Version-Release number of selected component:
python3-qtconsole-4.2.1-6.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python3 -s /usr/bin/jupyter-qtconsole-3
executable:     /usr/bin/jupyter-qtconsole-3
kernel:         4.11.10-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
qt_loaders.py:309:load_qt:ImportError: 
    Could not load requested Qt binding. Please ensure that
    PyQt4 >= 4.7, PyQt5 or PySide >= 1.0.3 is available,
    and only one is imported per session.

    Currently-imported Qt library:   None
    PyQt4 installed:                 False
    PyQt5 installed:                 False
    PySide >= 1.0.3 installed:       False
    Tried to load:                   ['pyqt5', 'pyside', 'pyqt']
    

Traceback (most recent call last):
  File "/usr/bin/jupyter-qtconsole-3", line 2, in <module>
    from qtconsole.qtconsoleapp import main
  File "/usr/lib/python3.5/site-packages/qtconsole/qtconsoleapp.py", line 60, in <module>
    from qtconsole.qt import QtCore, QtGui
  File "/usr/lib/python3.5/site-packages/qtconsole/qt.py", line 23, in <module>
    QtCore, QtGui, QtSvg, QT_API = load_qt(api_opts)
  File "/usr/lib/python3.5/site-packages/qtconsole/qt_loaders.py", line 309, in load_qt
    api_options))
ImportError: 
    Could not load requested Qt binding. Please ensure that
    PyQt4 >= 4.7, PyQt5 or PySide >= 1.0.3 is available,
    and only one is imported per session.

    Currently-imported Qt library:   None
    PyQt4 installed:                 False
    PyQt5 installed:                 False
    PySide >= 1.0.3 installed:       False
    Tried to load:                   ['pyqt5', 'pyside', 'pyqt']
    

Local variables in innermost frame:
api_options: ['pyqt5', 'pyside', 'pyqt']
api: 'pyqt'
loaded: None
loaders: {'pyside': <function import_pyside at 0x7ff6437feea0>, 'pyqtv1': functools.partial(<function import_pyqt4 at 0x7ff6437fed90>, version=1), 'pyqt5': <function import_pyqt5 at 0x7ff6437fee18>, 'pyqt': <function import_pyqt4 at 0x7ff6437fed90>, 'pyqtdefault': functools.partial(<function import_pyqt4 at 0x7ff6437fed90>, version=None)}
Comment 1 mov_ebpesp 2017-08-05 06:59:57 EDT
Created attachment 1309338 [details]
File: backtrace
Comment 2 mov_ebpesp 2017-08-05 06:59:58 EDT
Created attachment 1309339 [details]
File: environ
Comment 3 Mukundan Ragavan 2017-08-16 20:42:19 EDT
Can you install python3-qt5 and see if this issue goes away?
Comment 4 Fedora End Of Life 2017-11-16 10:21:47 EST
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2017-12-12 05:18:21 EST
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.