Bug 147867 - Kernel panic - not syncing ... net
Summary: Kernel panic - not syncing ... net
Status: CLOSED DUPLICATE of bug 147750
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-11 22:04 UTC by Frode Tennebø
Modified: 2015-01-04 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 13:11:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frode Tennebø 2005-02-11 22:04:16 UTC
Description of problem:
It appears that there is a problem with the networking subsystem. After what 
could very well be heavy network activity I get:

"Kernel panic - not suncing: net/ipv4/tcp_timer.c:213: spin_lock (net/core/sock.
c:C9E41060) already locked by net/ipv4/tcp_ipv4.c/1793"

The machine, in addition to my workstation, is also an iptables firewall with 
forwarding for several machines on my net.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.760_FC3

however, due to missing support for eata drivers I have added that from the .src 
package and also done some more minor changes:

[ft@leia linux-2.6.10]$ diff .config configs/kernel-2.6.10-i686.config |grep ^\<
< # Linux kernel version: 2.6.10-prep
< # Sun Feb  6 01:25:19 2005
< # CONFIG_M686 is not set
< CONFIG_MPENTIUMII=y
< # CONFIG_PM is not set
< # CONFIG_ACPI is not set
< # CONFIG_CPU_FREQ is not set
< CONFIG_PCI_NAMES=y
< CONFIG_HOTPLUG_PCI=m
< # CONFIG_HOTPLUG_PCI_SHPC_PHPRM_LEGACY is not set
< CONFIG_SCSI_EATA=m
< CONFIG_SCSI_EATA_TAGGED_QUEUE=y
< CONFIG_SCSI_EATA_LINKED_COMMANDS=y
< CONFIG_SCSI_EATA_MAX_TAGS=16
[ft@leia linux-2.6.10]$         

How reproducible:
quite often

Steps to Reproduce:
1. It happens in about 25% of apt-get update/upgrade tries, but also on some 
other occasions.
2.
3.
  
Actual results:
kernel panic

Expected results:
no kernel panic

Additional info:

Comment 1 Frode Tennebø 2005-02-12 13:11:07 UTC

*** This bug has been marked as a duplicate of 147750 ***


Note You need to log in before you can comment on or make changes to this bug.