Bug 1478752 - RHOS 12 unable to perform ovs+dpdk composable roles deployment
RHOS 12 unable to perform ovs+dpdk composable roles deployment
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Saravanan KR
Gurenko Alex
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-06 18:46 EDT by Maxim Babushkin
Modified: 2017-08-07 01:40 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 01:40:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ospd_12_templates (5.49 KB, application/x-gzip)
2017-08-06 18:48 EDT, Maxim Babushkin
no flags Details

  None (edit)
Description Maxim Babushkin 2017-08-06 18:46:50 EDT
Description of problem:
RHOS 12 unable to perform ovs+dpdk composable roles deployment.
Compute network configuration failed

Version-Release number of selected component (if applicable):
RHOS 12
Puddle - 2017-07-27.1

How reproducible:
Perform overcloud deployment with the templates attached

Actual results:
os-collect-config: [2017/08/06 03:00:41 PM] [INFO] running ifup on interface: ens1f1
os-collect-config: [2017/08/06 03:01:44 PM] [INFO] running ifup on interface: eno1
os-collect-config: [2017/08/06 03:02:14 PM] [INFO] running ifup on interface: ens2f1
os-collect-config: [2017/08/06 03:03:16 PM] [INFO] running ifup on interface: ens1f0
os-collect-config: [2017/08/06 03:03:47 PM] [ERROR] Failure(s) occurred when applying configuration
os-collect-config: [2017/08/06 03:03:47 PM] [ERROR] stdout:
os-collect-config: Determining IP information for ens1f1... failed.
os-collect-config: , stderr:
os-collect-config: [2017/08/06 03:03:47 PM] [ERROR] stdout:
os-collect-config: Determining IP information for ens2f1... failed.
os-collect-config: , stderr:
os-collect-config: Traceback (most recent call last):
os-collect-config: File "/usr/bin/os-net-config", line 10, in <module>
os-collect-config: sys.exit(main())
os-collect-config: File "/usr/lib/python2.7/site-packages/os_net_config/cli.py", line 206, in main
os-collect-config: activate=not opts.no_activate)
os-collect-config: File "/usr/lib/python2.7/site-packages/os_net_config/impl_ifcfg.py", line 1077, in apply
os-collect-config: raise os_net_config.ConfigurationError(message)
os-collect-config: os_net_config.ConfigurationError: Failure(s) occurred when applying configuration
os-collect-config: + RETVAL=1
os-collect-config: + set -e
os-collect-config: + [[ 1 == 2 ]]
os-collect-config: + [[ 1 != 0 ]]
os-collect-config: + echo 'ERROR: configuration of safe defaults failed.'
os-collect-config: [2017-08-06 15:03:47,880] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-script/d6b04b10-9f7f-4315-90a7-c03af7c5a545. [1]

Expected results:
Compute network configuration should pass

Additional info:
Comment 1 Maxim Babushkin 2017-08-06 18:48 EDT
Created attachment 1309777 [details]
ospd_12_templates
Comment 2 Maxim Babushkin 2017-08-06 18:53:00 EDT
The interfaces that are failed to configure are:
ens1f1 - control plane (linux_bond)
ens2f1 - dataplane - ovs+dpdk
Comment 3 Saravanan KR 2017-08-07 01:40:53 EDT
The deploy command overcloud_deploy.sh does not have the host config environment file, because of which, the kernel args are not set, resulting in this error. Can you follow the steps as mentioned in the document?
https://docs.google.com/document/d/1z9hl1IMCLfKoKcVn6c2izO20VueYFtt5-ZExoVPJ0r0/edit#heading=h.2wp8bweo5htm

Closing the BZ, as the provided templates will NOT work. Please use the document for the right templates. If you still face issues, with updated templates, raise it again.

Note You need to log in before you can comment on or make changes to this bug.