Bug 1478838 - gitg needs to be rebuilt against newer webkit for RHEL 7.4 update
gitg needs to be rebuilt against newer webkit for RHEL 7.4 update
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: gitg (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 05:21 EDT by Dominik Mierzejewski
Modified: 2017-08-28 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: gitg-3.22.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 12:19:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Mierzejewski 2017-08-07 05:21:44 EDT
Description of problem:
When upgrading RHEL 7.3 to RHEL 7.4, gitg has broken dependencies on libwebkit2gtk because webkitgtk4 package obsoletes libwebkit2gtk.

Version-Release number of selected component (if applicable):
gitg-3.14.1-1.el7.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. yum update libwebkit2gtk

Actual results:
Resolving Dependencies
--> Running transaction check
---> Package libwebkit2gtk.x86_64 0:2.4.9-6.el7 will be obsoleted
--> Processing Dependency: libwebkit2gtk-3.0.so.25()(64bit) for package: gitg-libs-3.14.1-1.el7.x86_64
--> Processing Dependency: libwebkit2gtk-3.0.so.25()(64bit) for package: gitg-3.14.1-1.el7.x86_64
---> Package webkitgtk4.x86_64 0:2.14.7-2.el7 will be obsoleting
--> Processing Dependency: webkitgtk4-plugin-process-gtk2(x86-64) = 2.14.7-2.el7 for package: webkitgtk4-2.14.7-2.el7.x86_64
--> Processing Dependency: webkitgtk4-jsc(x86-64) = 2.14.7-2.el7 for package: webkitgtk4-2.14.7-2.el7.x86_64
--> Processing Dependency: libjavascriptcoregtk-4.0.so.18()(64bit) for package: webkitgtk4-2.14.7-2.el7.x86_64
--> Processing Dependency: libhyphen.so.0()(64bit) for package: webkitgtk4-2.14.7-2.el7.x86_64
--> Running transaction check
---> Package hyphen.x86_64 0:2.8.6-5.el7 will be installed
---> Package libwebkit2gtk.x86_64 0:2.4.9-6.el7 will be obsoleted
--> Processing Dependency: libwebkit2gtk-3.0.so.25()(64bit) for package: gitg-libs-3.14.1-1.el7.x86_64
--> Processing Dependency: libwebkit2gtk-3.0.so.25()(64bit) for package: gitg-3.14.1-1.el7.x86_64
---> Package webkitgtk4-jsc.x86_64 0:2.14.7-2.el7 will be installed
---> Package webkitgtk4-plugin-process-gtk2.x86_64 0:2.14.7-2.el7 will be installed
--> Finished Dependency Resolution
Error: Package: gitg-3.14.1-1.el7.x86_64 (@epel)
           Requires: libwebkit2gtk-3.0.so.25()(64bit)
           Removing: libwebkit2gtk-2.4.9-6.el7.x86_64 (@rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Obsoleted By: webkitgtk4-2.14.7-2.el7.x86_64 (rhel-7-server-rpms)
              ~libwebkit2gtk-4.0.so.37()(64bit)
           Available: libwebkit2gtk-2.0.4-6.el7.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Available: libwebkit2gtk-2.0.4-6.el7_0.1.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Available: libwebkit2gtk-2.4.9-5.el7.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
Error: Package: gitg-libs-3.14.1-1.el7.x86_64 (@epel)
           Requires: libwebkit2gtk-3.0.so.25()(64bit)
           Removing: libwebkit2gtk-2.4.9-6.el7.x86_64 (@rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Obsoleted By: webkitgtk4-2.14.7-2.el7.x86_64 (rhel-7-server-rpms)
              ~libwebkit2gtk-4.0.so.37()(64bit)
           Available: libwebkit2gtk-2.0.4-6.el7.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Available: libwebkit2gtk-2.0.4-6.el7_0.1.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
           Available: libwebkit2gtk-2.4.9-5.el7.x86_64 (rhel-7-server-rpms)
               libwebkit2gtk-3.0.so.25()(64bit)
 You could try using --skip-broken to work around the problem

Expected results:
Update without broken dependencies.

Additional info:
Comment 1 Fedora Update System 2017-08-15 07:22:08 EDT
gitg-3.22.0-2.el7 libgit2-glib-0.24.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f4e48f88c1
Comment 2 Pete Walter 2017-08-15 07:25:59 EDT
Can you test the update and leave karma to https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-f4e48f88c1 please?
Comment 3 Fedora Update System 2017-08-28 12:19:30 EDT
gitg-3.22.0-2.el7, libgit2-glib-0.24.4-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.