Bug 1478887 - resize of the window causes UI error
resize of the window causes UI error
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
samuel macko
: Regression
: 1480072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 08:43 EDT by Lucie Leistnerova
Modified: 2017-12-20 06:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:04:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80343 master MERGED webadmin: fix ui exception 2017-08-09 14:33 EDT

  None (edit)
Description Lucie Leistnerova 2017-08-07 08:43:53 EDT
Description of problem:
Every resize of browser window causes UI error: olu(...).contentWindow is null

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170806164941.git514c1c9.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. log into admin portal
2. go to Virtual machines
3. resize window of the browser

Actual results: UI errors appear


Expected results: no UI error


Additional info:
ui.log

2017-08-07 14:21:32,278+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-11) [] Permutation name: 587DD5EF8832DAB414A2661F26562AEA
2017-08-07 14:21:32,288+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-11) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : olu(...).contentWindow is null
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_141]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_141]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:]
        at com.google.gwt.event.logical.shared.ResizeEvent.fire(ResizeEvent.java:40) [gwt-servlet.jar:]
        at com.google.gwt.user.client.Window.onResize(Window.java:862) [gwt-servlet.jar:]
        at Unknown.onresize<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/?locale=en_US)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:236) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:275) [gwt-servlet.jar:]
        at Unknown.Ku/<(https://host1.obfuscateddomain0.com/ovirt-engine/webadmin/?locale=en_US)
        at Unknown.anonymous(Unknown)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) : olu(...).contentWindow is null
        at org.ovirt.engine.ui.webadmin.section.main.view.DynamicUrlContentTabView.$lambda$1(DynamicUrlContentTabView.java:29)
        at org.ovirt.engine.ui.webadmin.section.main.view.DynamicUrlContentTabView$lambda$1$Type.onResize(DynamicUrlContentTabView.java:29)
        at com.google.gwt.event.logical.shared.ResizeEvent.dispatch(ResizeEvent.java:104) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.GwtEvent.dispatch(GwtEvent.java:76) [gwt-servlet.jar:]
        at com.google.web.bindery.event.shared.SimpleEventBus.$doFire(SimpleEventBus.java:173) [gwt-servlet.jar:]
        ... 8 more
Comment 1 Greg Sheremeta 2017-08-07 15:02:55 EDT
Same cause as Bug 1478020
Comment 2 Red Hat Bugzilla Rules Engine 2017-08-07 15:19:07 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Greg Sheremeta 2017-08-13 17:54:08 EDT
*** Bug 1480072 has been marked as a duplicate of this bug. ***
Comment 4 samuel macko 2017-08-30 07:32:59 EDT
Verified in ovirt version 4.2.0-0.0.master.20170828065003.git0619c76.el7.centos.

Verified by following the reproducer.
Comment 5 Sandro Bonazzola 2017-12-20 06:04:18 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.