Bug 1478899 - http_parser not deleted during the srpm build
http_parser not deleted during the srpm build
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: nodejs (Show other bugs)
rh-nodejs4
Unspecified Unspecified
unspecified Severity low
: ---
: 3.1
Assigned To: Zuzana Svetlikova
BaseOS QE - Apps
:
Depends On: 1478718
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 09:05 EDT by Cedric Buissart
Modified: 2017-11-20 06:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1478718
Environment:
Last Closed: 2017-11-20 06:42:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cedric Buissart 2017-08-07 09:05:24 EDT
+++ This bug was initially created as a clone of Bug #1478718 +++

Description of problem:
As shipped in RHSCL, the nodejs building process is supposed to pre-emptively delete unused dependencies from the deps/ directory.

However, there is a tiny typo for the http-parser dependency in the srpm spec file :

---8<----
142 rm -rf deps/npm \
143        deps/uv \
144        deps/http-parser \
145        deps/zlib
--->8----

The directory name is http_parser (underscore, not hyphen) :
$ ls node-v4.6.2/deps/
cares  gtest  http_parser  v8

Resulting in the deps/http_parser/ directory not being deleted as expected.

.... It does not change anything to the end result, but might be worth reporting ☺

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-08-06 16:39:40 CEST ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.
Comment 2 Cedric Buissart 2017-08-07 09:06:16 EDT
nodejs4 affected too

Note You need to log in before you can comment on or make changes to this bug.