Bug 1478953 - [Solved] cups-filters: _IO_file_doallocate(): pdftopdf killed by signal 11
[Solved] cups-filters: _IO_file_doallocate(): pdftopdf killed by signal 11
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
: 1479581 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2017-08-07 10:51 EDT by capitan.terrore
Modified: 2017-09-01 04:44 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-09-01 03:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (70.79 KB, text/plain)
2017-08-07 10:51 EDT, capitan.terrore
no flags Details
File: cgroup (253 bytes, text/plain)
2017-08-07 10:51 EDT, capitan.terrore
no flags Details
File: core_backtrace (3.13 KB, text/plain)
2017-08-07 10:51 EDT, capitan.terrore
no flags Details
File: cpuinfo (1.35 KB, text/plain)
2017-08-07 10:51 EDT, capitan.terrore
no flags Details
File: dso_list (3.80 KB, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: environ (906 bytes, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: exploitable (93 bytes, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: limits (1.29 KB, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: maps (18.45 KB, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: open_fds (735 bytes, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: proc_pid_status (1.23 KB, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details
File: var_log_messages (323 bytes, text/plain)
2017-08-07 10:52 EDT, capitan.terrore
no flags Details

  None (edit)
Description capitan.terrore 2017-08-07 10:51:45 EDT
Description of problem:
During  brother printer installation mfc-7420

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        MFC7420 1 root testprint 1 finishings=3 number-up=1 job-uuid=urn:uuid:56f39d54-1931-31ed-70c0-d1b3d1ffee35 job-originating-host-name=localhost date-time-at-creation= date-time-at-processing= time-at-creation=1502106851 time-at-processing=1502106851 document-name-supplied=testprint
crash_function: _IO_file_doallocate
executable:     /usr/lib/cups/filter/pdftopdf
journald_cursor: s=0f15580559ec4bc3aa5d0c7b48faf71b;i=c6d;b=a0c051b667b44a5f9eedac3933e6b0b2;m=2e4520b1;t=556288150d840;x=6a9d33ae53d5b140
kernel:         4.11.11-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            4

Truncated backtrace:
Thread no. 1 (7 frames)
 #2 _IO_file_doallocate at filedoalloc.c:101
 #3 _IO_doallocbuf at genops.c:398
 #4 _IO_new_file_seekoff at fileops.c:1031
 #5 fseeko at fseeko.c:36
 #6 FileInputSource::seek at libqpdf/FileInputSource.cc:108
 #7 QPDF::processFile at libqpdf/QPDF.cc:141
 #8 QPDF_PDFTOPDF_Processor::loadFile at filter/pdftopdf/qpdf_pdftopdf_processor.cc:407
Comment 1 capitan.terrore 2017-08-07 10:51:54 EDT
Created attachment 1310142 [details]
File: backtrace
Comment 2 capitan.terrore 2017-08-07 10:51:56 EDT
Created attachment 1310143 [details]
File: cgroup
Comment 3 capitan.terrore 2017-08-07 10:51:57 EDT
Created attachment 1310144 [details]
File: core_backtrace
Comment 4 capitan.terrore 2017-08-07 10:51:59 EDT
Created attachment 1310145 [details]
File: cpuinfo
Comment 5 capitan.terrore 2017-08-07 10:52:00 EDT
Created attachment 1310146 [details]
File: dso_list
Comment 6 capitan.terrore 2017-08-07 10:52:02 EDT
Created attachment 1310147 [details]
File: environ
Comment 7 capitan.terrore 2017-08-07 10:52:04 EDT
Created attachment 1310148 [details]
File: exploitable
Comment 8 capitan.terrore 2017-08-07 10:52:05 EDT
Created attachment 1310149 [details]
File: limits
Comment 9 capitan.terrore 2017-08-07 10:52:07 EDT
Created attachment 1310150 [details]
File: maps
Comment 10 capitan.terrore 2017-08-07 10:52:09 EDT
Created attachment 1310151 [details]
File: open_fds
Comment 11 capitan.terrore 2017-08-07 10:52:10 EDT
Created attachment 1310152 [details]
File: proc_pid_status
Comment 12 capitan.terrore 2017-08-07 10:52:12 EDT
Created attachment 1310153 [details]
File: var_log_messages
Comment 13 Robert Strube 2017-08-07 13:00:20 EDT
I'm also experiencing a crash with pdftopdf when attempting to print different types of files (plain text, PDF, etc.).

Printer: Brother DCP-7020
Driver: Brother DCP-7020 Foomatic/hl1250 (recommended)

cups-filters: 1.13.4-2.fc26
kernel: 4.11.11-300.fc26.x86_64

I apologize but I'm not familiar with how to create a backtrace, although I would very happily learn.  You can see my CUPS error log here: https://pastebin.com/vmG61jVe
Comment 14 Robert Strube 2017-08-07 13:05:41 EDT
I did find this additional information:

Process 7283 (pdftopdf) of user 4 dumped core.

Stack trace of thread 7283:
#0  0x00007f3cf8e5419f _int_malloc (libc.so.6)
#1  0x00007f3cf8e579b8 malloc (libc.so.6)
#2  0x00007f3cf8e3c52c _IO_file_doallocate (libc.so.6)
#3  0x00007f3cf8e4c399 _IO_doallocbuf (libc.so.6)
#4  0x00007f3cf8e48a73 _IO_file_seekoff@@GLIBC_2.2.5 (libc.so.6)
#5  0x00007f3cf8e46f29 fseeko (libc.so.6)
#6  0x00007f3cfb5cc965 _ZN15FileInputSource4seekExi (libqpdf.so.17)
#7  0x00007f3cfb5e3103 _ZN4QPDF11processFileEPKcP8_IO_FILEbS1_ (libqpdf.so.17)
#8  0x000055b388226b0a _ZN23QPDF_PDFTOPDF_Processor8loadFileEP8_IO_FILE12ArgOwnership (pdftopdf)
#9  0x000055b38821d59c main (pdftopdf)
#10 0x00007f3cf8deb4da __libc_start_main (libc.so.6)
#11 0x000055b38821d82a _start (pdftopdf)

I realize this most likely isn't very helpful, but I thought I would share regardless.
Comment 15 Robert Strube 2017-08-07 13:26:20 EDT
Similar problem has been detected:

1. Plugged in printer (Brother DCP-7202).  Printer was detected and proper driver was installed: (Brother DCP-7020 Foomatic/hl1250 (recommended)
2. Try to print any file (plain text, PDF, etc.) and you print job will start and then immeditately stop.
3. If you enable CUPS debugging you will see that the job failing is a result of filter errors, specifically /usr/lib/cups/filter/pdftopdf

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        DCP-7020 8 robert Test Page 1 job-uuid=urn:uuid:09d9482a-1589-3525-4c28-3dde751dbad3 job-originating-host-name=localhost date-time-at-creation= date-time-at-processing= time-at-creation=1502114420 time-at-processing=1502114420
crash_function: _IO_file_doallocate
executable:     /usr/lib/cups/filter/pdftopdf
journald_cursor: s=f07caca9897649e5a7b17d64b8797067;i=ad72;b=1734d0dbd32341a1963e98fbdc1e7b34;m=2424b7cf;t=5562a446c880f;x=6f32fe77bd67b58e
kernel:         4.11.11-300.fc26.x86_64
package:        cups-filters-1.13.4-2.fc26
reason:         pdftopdf killed by signal 11
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            4
Comment 16 Dominique Brazziel 2017-08-07 14:26:41 EDT
I got hit by this bug this morning.  While I was generating an abrt report a message popped up about an update to qpdf. Trying to track down which version that might be, dnf tells me I am up to date on qpdf-libs, and just installed the qpdf package.
Comment 17 Zdenek Dohnal 2017-08-07 17:15:12 EDT

thank you for reporting this issue, it is cause by change in qpdf, would you mind downgrading qpdf-libs package for now? Update reverting changes which caused this issue is in update-testing repository.
Comment 18 Robert Strube 2017-08-07 18:19:47 EDT
I can confirm that downgrading to qpdf-libs.x86_64                      6.0.0-5.fc26 fixed this issue for me.  Thanks for the suggestion!
Comment 19 capitan.terrore 2017-08-08 01:07:49 EDT
I apologize for my low attendance but it was late here in italy ..XD
I confirm that a qpdrf-libs downgrade fixes the problem ..
After removing the repo version, I installed 6.0.0 v3 because the 4 failed to download https://www.rpmfind.net/linux/rpm2html/search.php?query=qpdf-libs and then I reinstalled Drivers .. Now prints work ..
Thanks guys: D
Ah .. Sorry my english I'm doing with the google translator
Comment 20 Jose Mantilla 2017-08-08 16:59:41 EDT
Yes, I wake up with this error due to an update I did yesterday.

abrt-notification: Process 5806 (pdftopdf) crashed in malloc()
Aug  8 15:36:26 samba cupsd: Job stopped due to filter errors; please consult the error_log file for details.

After I put the LogLevel to debug I always see the error in the subscription file of cups.

Comment 21 hiko.imada 2017-08-08 17:06:45 EDT
*** Bug 1479581 has been marked as a duplicate of this bug. ***
Comment 22 Michele Baldessari 2017-08-09 11:12:38 EDT
FYI Same here. qpdf-libs-6.0.0-6.fc26.x86_64 makes pdftopdf crash and downgrading to qpdf-libs-6.0.0-5.fc26.x86_64 makes it work again.
Comment 23 Robert Strube 2017-08-10 16:13:27 EDT
I see that qpdf-libs-6.0.0-7.fc26.x86_64 is now available.  I can confirm after updating to this version the crash with pdftopdf is resolved.  Not sure if this bug can be closed now or if it needs to remain open to track the original issue?
Comment 24 morphey 2017-08-11 03:41:38 EDT
I can confirm after this update the problem is resolved!
Comment 25 Zdenek Dohnal 2017-08-11 07:13:49 EDT

I would like to leave this bugzilla open for now, because today I will submit the update, which should have CVE patches (which caused binary incompatibility with cups-filters, which caused this issue - solution was rebuild cups-filters with qpdf-libs) and rebuilt cups-filters package. I would like to ask you after that for testing this update, if it works correctly.
Comment 26 Zdenek Dohnal 2017-08-11 09:50:43 EDT
Hi everyone,

would you mind testing this update https://bodhi.fedoraproject.org/updates/cups-filters-1.13.4-3.fc26%20qpdf-6.0.0-8.fc26 ? This update puts back patches for CVEs in qpdf, which were in qpdf-libs-6.0.0-6.fc26 version, but it created binary incompatibility, which caused segfaults in cups-filters. It should be solved by rebuild of cups-filters against new qpdf-libs release (cups-filters rebuild is part of update). I didn't set auto-push to stable on this update, because I want to push it manually after I get positive feedback about its functionality.
Comment 27 Nate Straz 2017-08-16 09:51:40 EDT
Yes, printing is working for me with the new cups-filters and qpdf-libs packages.
Tested with a Brother HL-2280DW and Brother printer drivers.
Comment 28 Robert Strube 2017-08-28 17:31:42 EDT
Sorry for the late reply.

I did test out qpdf-libs.x86_64 6.0.0-8.fc26 and can confirm that it's working great.  No segfaults with pdftopdf anymore, and the CVE patches are in that package.

I would say you can safely close out this bug at this point.

Thanks for the help!
Comment 29 Zdenek Dohnal 2017-09-01 03:34:37 EDT
Thank you for testing! Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.