Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 147917 - DSL connection gets terminated after a while and modem needs to be reset to reconnect
DSL connection gets terminated after a while and modem needs to be reset to r...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 15:16 EST by Dennis Jacobfeuerborn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-02 17:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2005-02-12 15:16:01 EST
Description of problem:
I recently replaced my old router (od Redhat 7.3 pc with an AVM
FritzCard DSL) with a D-Link DSL modem/router but my connection got
terminated after about beeing online for somewhere between 30 minutes
and 2 hours. The only way I was able to get online again was to reset
the modem.
Since I believed the modem might be damaged I returned it to the store
and got myself a Devolo MicroLink ADSL Fun LAN instead only to find
out that it has the same problems. So in order to check if the modem
is ok I tested it under Windows and there it works flawlessly so it
seems to be Fedora that is creating the problems. Here is the output
that I get in /var/log/messages when the disconnect happens:

Feb 12 03:59:43 nexus pppd[10459]: LCP: timeout sending Config-Requests 
Feb 12 03:59:43 nexus pppd[10459]: Connection terminated.
Feb 12 03:59:47 nexus pppoe[10462]: Timeout waiting for PADO packets
Feb 12 03:59:47 nexus pppd[10459]: Exit.
Feb 12 03:59:47 nexus adsl-connect: ADSL connection lost; attempting
re-connection.
Feb 12 03:59:52 nexus pppd[10484]: pppd 2.4.2 started by root, uid 0
Feb 12 03:59:52 nexus pppd[10484]: Using interface ppp0
Feb 12 03:59:52 nexus pppd[10484]: Connect: ppp0 <--> /dev/pts/0
Feb 12 04:00:01 nexus crond(pam_unix)[10496]: session opened for user
root by (uid=0)
Feb 12 04:00:01 nexus crond(pam_unix)[10496]: session closed for user root
Feb 12 04:00:23 nexus pppd[10484]: LCP: timeout sending Config-Requests 

This gets repeated over and over as Fedora tries to reconnect but it
fails to do so until I reset the modem. I also noticed that I get a
lot of "pppd[5193]: Protocol-Reject for unsupported protocol 0x901a"
messages in the log while the connection is working.


Version-Release number of selected component (if applicable):
I used the versions of pppd and rp-pppoe that came with FC3 and I also
recompiled the latest version in rawhide (using rpmbuild --rebuild).

Steps to Reproduce:
1. Establish PPPoE connection successfully
2. Surf for a while
  
Actual results:
Connection gets terminated

Expected results:
Connection continues to work

Additional info:
There are two things I'm going to try now:
1. Instead of resetting the modem I'm going to reboot Fedora to make
sure it isn't anything Fedora/Kernel related that "wedges" the modem.

2. I'll try to install PPPoE on my old router and setup the modem
there to see if the same problem appears under RH7.3 .
Comment 1 Dennis Jacobfeuerborn 2005-05-02 17:17:24 EDT
I was finally able to track this issue down to a defective splitter so this bug
is no longer valid.

Note You need to log in before you can comment on or make changes to this bug.