Bug 1479458 - disper: Missing build-time dependency on python2-devel
disper: Missing build-time dependency on python2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: disper (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Santagiuliana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 11:06 EDT by Iryna Shcherbina
Modified: 2017-08-18 06:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: disper-0.3.1-9.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 10:43:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add build-time dependency on python2-devel (1.43 KB, application/mbox)
2017-08-08 11:06 EDT, Iryna Shcherbina
no flags Details

  None (edit)
Description Iryna Shcherbina 2017-08-08 11:06:04 EDT
Created attachment 1310658 [details]
Add build-time dependency on python2-devel

The disper RPM is missing the build-time dependency on python2-devel.

This is the reason why the dependency on Python itself is not generated for disper-0.3.1-8.fc27:

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --requires disper | grep python
<nothing>


According to Fedora Packaging Guidelines for Python [0], packages building for Python 2 need BuildRequires: python2-devel.

I have attached the patch which adds a missing build-time dependency and modernizes the spec file. Please review it and apply.

[0] https://fedoraproject.org/wiki/Packaging:Python#Dependencies
Comment 1 Jan Kurik 2017-08-15 02:56:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 Iryna Shcherbina 2017-08-15 18:03:23 EDT
Also opened a Pagure PR: https://src.fedoraproject.org/rpms/disper/pull-request/1
Comment 3 Tomas Orsava 2017-08-16 10:43:25 EDT
I merged the PR.

Note You need to log in before you can comment on or make changes to this bug.