Bug 1479569 - [DOCS] For disconnected installs, please correct the container/image tags [NEEDINFO]
[DOCS] For disconnected installs, please correct the container/image tags
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Brandi
Gan Huang
Vikram Goyal
3.10-release-plan
:
Depends On:
Blocks: 1542093
  Show dependency treegraph
 
Reported: 2017-08-08 16:23 EDT by Thom Carlin
Modified: 2018-06-28 14:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 14:15:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bmcelvee: needinfo? (mburke)


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2017-08-08 16:23:20 EDT
Document URL: 

https://access.redhat.com/documentation/en-us/openshift_container_platform/3.5/html-single/installation_and_configuration/#install-config-install-disconnected-install

Section Number and Name: 

2.7.3.1. SYNCING REPOSITORIES

Describe the issue: 

The tags used don't work with all the containers/images specified or are out of date.

Suggestions for improvement: 

Test each image.  I believe "v3.5" would be a better tag but have not exhaustively tested.

Additional information: 

For example, https://access.redhat.com/containers/?tab=tags#/registry.access.redhat.com/openshift3/logging-auth-proxy has the 3.5.0 tag 
but https://access.redhat.com/containers/?tab=tags#/registry.access.redhat.com/openshift3/logging-deployer does not:

docker pull registry.access.redhat.com/openshift3/logging-deployer:3.5.0
Trying to pull repository registry.access.redhat.com/openshift3/logging-deployer ... 
error parsing HTTP 404 response body: invalid character 'F' looking for beginning of value: "File not found.\""
Comment 1 Thom Carlin 2017-08-09 09:50:20 EDT
Additional information:
* ose-sti-builder will not appear on access.redhat.com because it is marked as DEPRECATED
* jboss-eap70-openshift appears twice in the S2I list
* S2I applications listed appear to be out of date.  For example, JBoss AMQ has both 6.2 and 6.3, JBoss Decision Server 6.2 is DPRECATED, 6.3 and 6.4 are available
Comment 6 Michael Burke 2018-05-14 13:50:08 EDT
Brandi --

I don't recall exactly; But, it appears that the officially supported versions of the images for 3.7 was not available in the Tested Integrations matrix [1] at the time. It appears to have been added on December 8 2017 [2]

[1] https://access.redhat.com/articles/2176281
[2] https://access.redhat.com/node/2176281/moderation/diff/view/10480181/10846311 

I would think it OK to update the page for 3.7+

Michael
Comment 7 Gan Huang 2018-05-15 05:52:18 EDT
Go through the latest 3.5 document. This should be addressed now. The images exist on official registry.

registry.access.redhat.com/openshift3/ose-sti-builder:v3.5.5.31.48

registry.access.redhat.com/openshift3/logging-deployer:v3.5

Note You need to log in before you can comment on or make changes to this bug.