Bug 147958 - RSS feed of RHN available errata
Summary: RSS feed of RHN available errata
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
(Show other bugs)
Version: RHN Stable
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: rhn-dev-list
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-14 02:36 UTC by David Jericho
Modified: 2012-02-10 12:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 12:24:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Jericho 2005-02-14 02:36:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
We have a significant number of RHEL entitlements, but for reasons I won't elaborate on, management isn't done through the RHN. Package management is all done from a central config and image system.

RHN errata mailouts are handy, but it would be nice if I could automate the collection of errata with some form of RSS or Atom feed.



Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
No steps to involved.

Expected Results:  An RSS feed, accessed via RHN with username and password, with direct links contained within for all errata for permitted channels, or even just channel based RSS feeds. 

Something akin to https://username:password@rhn.redhat.com/rhel3ws-errata.rss to list all RHEL 3 Workstation errata, and slurp the direct links for the relevant rpms directly.

Additional info:

Comment 5 Sebastian Skracic 2012-02-10 12:24:48 UTC
There is https://rhn.redhat.com/rpc/recent-errata.pxt

About the downloadable RPM links: it is our policy to expose only timebombed download URLs with a reasonably short TTL (10 minutes) and only on authenticated pages.


Note You need to log in before you can comment on or make changes to this bug.