Bug 1479813 - hamster-time-tracker: Missing build-time dependency on python2-devel
hamster-time-tracker: Missing build-time dependency on python2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 08:53 EDT by Iryna Shcherbina
Modified: 2017-08-18 08:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: hamster-time-tracker-2.0-0.12.rc1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 10:47:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add a build-time dependency on python2-devel (1.47 KB, application/mbox)
2017-08-09 08:53 EDT, Iryna Shcherbina
no flags Details

  None (edit)
Description Iryna Shcherbina 2017-08-09 08:53:44 EDT
Created attachment 1311199 [details]
Add a build-time dependency on python2-devel

A build-time dependency on python2-devel is missing.

This is the reason why the dependency on Python itself is not generated for hamster-time-tracker-2.0-0.11.rc1.fc27:

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --requires hamster-time-tracker | grep python
dbus-python
gnome-python2-gconf
gnome-python2-libwnck
python-gobject


According to Fedora Packaging Guidelines for Python [0], packages building for Python 2 need BuildRequires: python2-devel.

I have attached the patch which adds a missing build-time dependency. Please review it and apply.

[0] https://fedoraproject.org/wiki/Packaging:Python#Dependencies
Comment 1 Jan Kurik 2017-08-15 03:31:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 Iryna Shcherbina 2017-08-15 18:10:04 EDT
Also opened a Pagure PR with the patch: https://src.fedoraproject.org/rpms/hamster-time-tracker/pull-request/1
Comment 3 Tomas Orsava 2017-08-16 10:47:23 EDT
I merged the PR.

Note You need to log in before you can comment on or make changes to this bug.