Bug 1479861 - python-atfork: Missing build-time dependency on python2-devel
python-atfork: Missing build-time dependency on python2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-atfork (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Laska
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 11:11 EDT by Iryna Shcherbina
Modified: 2017-08-18 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-atfork-0.1.2-13.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-18 06:42:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add a build-time dependency on python2-devel (2.47 KB, application/mbox)
2017-08-09 11:11 EDT, Iryna Shcherbina
no flags Details

  None (edit)
Description Iryna Shcherbina 2017-08-09 11:11:08 EDT
Created attachment 1311255 [details]
Add a build-time dependency on python2-devel

A build-time dependency on python2-devel is missing.

This is the reason why the dependency on Python itself is not generated for python-atfork-0:0.1.2-12.fc27:

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --requires python-atfork | grep python
<nothing>


According to Fedora Packaging Guidelines for Python [0], packages building for Python 2 need BuildRequires: python2-devel.

I have attached the patch which adds a missing build-time dependency and modernizes the spec file. Please review it and apply.

[0] https://fedoraproject.org/wiki/Packaging:Python#Dependencies
Comment 1 Jan Kurik 2017-08-15 04:25:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 2 Iryna Shcherbina 2017-08-15 18:23:20 EDT
Also created a Pagure PR with a patch:

https://src.fedoraproject.org/rpms/python-atfork/pull-request/1
Comment 3 Tomas Orsava 2017-08-16 10:59:28 EDT
I merged the PR.

Note You need to log in before you can comment on or make changes to this bug.