Bug 148001 - GFS-modules package appears to be running depmods on the currently running kernel instead of the kernel it depends on
GFS-modules package appears to be running depmods on the currently running ke...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
: 147640 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 12:10 EST by AJ Lewis
Modified: 2010-01-11 22:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 15:39:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description AJ Lewis 2005-02-14 12:10:15 EST
Description of problem:
GFS-modules package appears to be running depmods on the currently running
kernel instead of the kernel it depends on.  I noticed this after removing a
kernel package for the currently running kernel on a system, then installing the
GFS modules package.

Version-Release number of selected component (if applicable):
6.0.2-25

How reproducible:
Haven't tried.

Steps to Reproduce:
1. Boot system with a kernel other than the one the GFS-modules package depends on
2. rpm -e that kernel package
3. install the GFS-modules package
  
Actual results:
# rpm -U GFS-*
depmod: Can't open /lib/modules/2.4.21-27.4.ELsmp/modules.dep for writing
error: %post(GFS-modules-smp-6.0.2-25) scriptlet failed, exit status 255

where 2.4.21-27.4.ELsmp is the kernel package that was just removed, and
2.4.21-27.0.2.ELsmp is the kernel package the GFS module depend on.

Expected results:
No error.

Additional info:
Comment 1 Adam "mantis" Manthei 2005-02-14 12:23:26 EST
This is because the GFS-modules rpm is making the assumption that when GFS was
installed, it was booted into the same version that GFS uses when it runs:

[void] rpm -q -p --scripts GFS-modules-6.0.2-25.i686.rpm   
postinstall scriptlet (using /bin/sh):
depmod -a

The system map needs to also be passed to depmod:
depmod -ae -F /boot/System.map-2.4.21-27.0.2.ELsmp 2.4.21-27.0.2.ELsmp
Comment 2 Chris Feist 2005-02-14 14:03:39 EST
This has been added to the latest 6.0.2 build.  And just needs to be verified on
the next build.
Comment 3 Adam "mantis" Manthei 2005-02-14 14:11:06 EST
*** Bug 147640 has been marked as a duplicate of this bug. ***
Comment 4 Lon Hohberger 2009-12-22 15:39:00 EST
Cleanup.

This bugzilla should be resolved with the current packages from RHN for Red Hat Global File System for Red Hat Enterprise Linux 3.

GFS-6.0.2.36-9

Note You need to log in before you can comment on or make changes to this bug.