Bug 1480070 - Update mail notification from server
Update mail notification from server
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
26
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 01:31 EDT by Lukas Slebodnik
Modified: 2017-08-10 17:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 17:32:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github fedora-infra/bodhi/issues/1741 None None None 2017-08-10 17:32 EDT

  None (edit)
Description Lukas Slebodnik 2017-08-10 01:31:51 EDT
Description of problem:
I got a notification from bodhi-server that my update reached enough days in updated-testing. But number is wrong.

Web page says that it was in testing for 14 days
  https://bodhi.fedoraproject.org/updates/FEDORA-2017-91b708222e
Mail says: 7 days

  Date: Thu, 10 Aug 2017 00:00:34 +0000 (UTC)                                                               
  From: updates@fedoraproject.org                                                                           
  To: lslebodn@fedoraproject.org                                                                                   
  Subject: [Fedora Update] [CRITPATH] [comment] sssd                                                        
                                                                                                          
  The following comment has been added to the sssd-1.15.3-1.fc25 update:                                    
                                                                                                          
  bodhi - 2017-08-10 00:00:33.650648 (karma: 0)                                                             
  This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes        
                                                                                                          
  To reply to this comment, please visit the URL at the bottom of this mail                                 
                                                                                                          
  ==============================================================================                          
     sssd-1.15.3-1.fc25                                                                                   
  ==============================================================================                          
    Update ID: FEDORA-2017-91b708222e                                                                       
      Release: Fedora 25                                                                                    
       Status: testing                                                                                      
         Type: enhancement                                                                                  
        Karma: 3
  Version-Release number of selected component (if applicable):


Comments in webpage says:
   This update has been submitted for testing by lslebodn. 15 days ago
   This update has been pushed to testing. 14 days ago
   This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes  5 hours ago
   This update has been submitted for stable by lslebodn. 17 minutes ago



How reproducible:
Probably every time.


Additional info:

It is a really minor issue but at least you will know about it :-)
Comment 1 Randy Barlow 2017-08-10 17:32:12 EDT
Ah, I bet the template code for the number 7 failed to consider that the update was critical path, and critical path updates have a 14 day requirement instead of 7 days. So basically, the template always puts 7 there, but the comment happens at 14 days for critical updates.

I'm going to refile this at GitHub since this isn't a packaging issue. Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.