Bug 1480096 - windows 7 hung after live-migrate
windows 7 hung after live-migrate
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Eoghan Glynn
Joe H. Rahme
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-10 03:13 EDT by uljtg
Modified: 2017-08-11 10:43 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 10:43:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description uljtg 2017-08-10 03:13:22 EDT
Description of problem:
windows 7 hung after live-migrate

Version-Release number of selected component (if applicable):
kernel: 3.10.0-327.28.3.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7

How reproducible:


Steps to Reproduce:
1. install redhat 7.2
2. install openstack liberty
3. glance upload windows7 images
4. create a vm from the image upload in step 3
5. use nova live-migration to migrate vm to other node
6. use vnc to connect vm.
7.  

Actual results:
 vm hung(can see the desktop, but mouse and keyboard can not take any affect)

Expected results:
 vm not hung

Additional info:
Comment 1 Sahid Ferdjaoui 2017-08-11 05:37:05 EDT
Not sure if that is really related since no logs are provided but that one looks to be similar:

  https://bugzilla.redhat.com/show_bug.cgi?id=1376806
Comment 2 Artom Lifshitz 2017-08-11 10:43:09 EDT
Like Sahid said, what you're describing sounds like an issue that's been fixed in qemu 2.6, available in rhel7.3. Please upgrade to rhel7.3 and check whether that fixes the issue that you've reported. I'm going to close this bug for now - feel free to reopen it if the issue persists with rhel7.3. If you do reopen this bug, please include the full version of OpenStack that you're using, for example: openstack-nova-2015.1.3-1.el7ost. Please note that commercial support is only available Red Hat OpenStack Platform, and not the RDO community distribution.

Note You need to log in before you can comment on or make changes to this bug.